Bug 1360427 - RPM of sub-man-gui does not depend on any web browser
Summary: RPM of sub-man-gui does not depend on any web browser
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: Jan Stavel
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 17:23 UTC by Jan Stavel
Modified: 2017-08-01 19:18 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:18:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
Subscription-manager error when tried to open online documentation on a system with no browser (79.64 KB, image/png)
2017-05-08 09:04 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1504 None None None 2016-10-05 20:55:04 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Jan Stavel 2016-07-26 17:23:43 UTC
Description of problem:

I have RHEL server with desktop installed lately. No browser is installed.

When I click on "online documentation" I see gedit with html source of a page. It is not readable anymore.

Version-Release number of selected component (if applicable):


How reproducible:

Everytime.

Steps to Reproduce:
1. Install server variant
2. Install group "Server with GUI"
3. verify that no web browser is installed
4. click on "online documentation"


Actual results:

gedit shows html raw code.

Expected results:

Something better readable.

You can ensure that firefox is installed or if w3m/lynx is installed,
you can render the html source this way:

lynx -dump -width 80

Additional info:

Comment 2 Chris Snyder 2016-07-29 20:44:00 UTC
Out of curiosity, how did you end up without firefox installed after installing the group "Server with GUI"?

Comment 3 Jan Stavel 2016-08-01 07:52:40 UTC
Hi Chris,
I have created a server without any gui in central-ci.
If I remember well, I have installed group "Server with GUI".

I may be wrong with the group I have installed. But the thing I am sure is that I have started with server without any gui. After that I have installed some group to test subscription-manager-gui.

If it is important for you, I will try to reproduce this.

Have a good day,
Jan

Comment 4 vritant 2016-08-01 19:57:07 UTC
Jan,
It seems that the server with GUI installation seems incomplete. We ship firefox with "Server with GUI", so please provide details of reproducer steps.

Comment 5 Jan Stavel 2016-08-02 08:22:08 UTC
Hi Vritant,
I will do my best for reproducing that.

Have a good day,
Jan

Comment 6 Jan Stavel 2016-08-02 09:30:01 UTC
Hello Vritant.
you are right.

group "Server with GUI" contains of "firefox".

The right way to install subscription-manager-gui without firefox is:


*** launch instance from an image "rhel-7.2-server-x86_64-released"
    http://dashboard.centralci.eng.rdu2.redhat.com/dashboard/project/instances/

*** register against subscription.rhsm.stage.redhat.com

*** install ddns client
    server name is jstavel-gui-without-firefox.usersys.redhat.com

*** system summary

   #+RESULTS:
   #+begin_example
   Red Hat Enterprise Linux Server release 7.2 (Maipo)
   ----------------------------     ----------------------------
   arch                             x86_64
   kernel version                   3.10.0-327.el7.x86_64
   ----------------------------     ----------------------------
   server type                      Red Hat Subscription Management
   subscription management server   0.9.51.15-1
   subscription management rules    5.15.1
   subscription-manager             1.15.9-15.el7
   python-rhsm                      1.15.4-5.el7
   ----------------------------     ----------------------------
   Product                          69.pem
   ----------------------------     ----------------------------
   Entitlement                      6908967970137959630.pem
   ----------------------------     ----------------------------
#+end_example


*** yum -y groupinstall gnome-desktop

*** subscription-manager-gui has appeared, firefox has not

    which subscription-manager-gui
    which firefox   2>&1
    exit 0

    #+RESULTS:
    : /usr/bin/subscription-manager-gui
    : which: no firefox in (/usr/bin:/bin:/sbin:/usr/sbin:/usr/local/bin:/usr/local/sbin)

Comment 7 Jan Stavel 2016-08-02 09:39:47 UTC
Hello Vritant,
I have noticed that there is a group "Internet Browser" among available install groups.

It seems to be good requirement candidate for subscription-manager-gui.

Have a good day,
Jan

Comment 10 Jan Stavel 2016-08-12 10:13:59 UTC
Hello Vritant,
I have tried those variants of gnome-help usage:

gnome-help /tmp/aa.html
-> the app opens a window with a message "URL cannot be shown" inside

gnome-help http://www.redhat.com
-> the app opens empty window and new tab in firefox on lauches firefox.

gnome-help file:///tmp/aa.html
-> the app opens a window with a message "URL cannot be shown" inside

Comment 12 Shwetha Kallesh 2017-05-08 09:04:42 UTC
Created attachment 1277061 [details]
Subscription-manager error when tried to open online documentation on a system with no browser

[root@dhcp71-2 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.12-1.el7
python-rhsm: 1.19.6-1.el7

Comment 13 errata-xmlrpc 2017-08-01 19:18:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.