This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 136049 - unnecessary O_NONBLOCK on descriptor for disk file breaks with .624 kernel
unnecessary O_NONBLOCK on descriptor for disk file breaks with .624 kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
:
Depends On: 136057
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-17 03:05 EDT by Ulrich Drepper
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 10:56:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to remove unnecessary O_NONBLOCK use (495 bytes, patch)
2004-10-17 03:07 EDT, Ulrich Drepper
no flags Details | Diff

  None (edit)
Description Ulrich Drepper 2004-10-17 03:05:54 EDT
Description of problem:
The .624 kernel has this questionable feature that read for files on
disk can return EAGAIN.  squid breaks badly if this happens since this
is not considered as a recoverable error.  The attached patch seems to
fix it.

Version-Release number of selected component (if applicable):
squid-2.5.STABLE6-2

How reproducible:
always

Steps to Reproduce:
1.start squid on .624 kernel
2.
3.
  
Actual results:
bails out with errors about not being able to read
/etc/squid/errors/ERR_READ_TIMEOUT or a similar file.

Expected results:
Should start up.

Additional iI'll attach a patch which should fix it.  Works for me at
least.
Comment 1 Ulrich Drepper 2004-10-17 03:07:13 EDT
Created attachment 105345 [details]
patch to remove unnecessary O_NONBLOCK use
Comment 2 Bill Nottingham 2004-10-20 01:26:19 EDT
kernel is fixed, deescalating
Comment 3 Jay Fenlason 2004-10-20 10:56:59 EDT
New squid in rawhide with patch, too. 

Note You need to log in before you can comment on or make changes to this bug.