Bug 136060 - console=tty0 implicitly appended to x86_64 command line breaks init=/bin/bash
Summary: console=tty0 implicitly appended to x86_64 command line breaks init=/bin/bash
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
low
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-17 09:37 UTC by Alexandre Oliva
Modified: 2015-01-04 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 03:53:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2004-10-17 09:37:15 UTC
Description of problem:
arch/x86_64/kernel/head64.c appends ` console=tty0' to the kernel
command line if there isn't a `console=' string in there.  If your
grub command line doesn't specify console=tty0, and you just append
`init=/bin/bash' to the command line, you won't get a shell prompt,
because console=tty is going to be passed to bash.

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.624

How reproducible:
Every time

Steps to Reproduce:
1.cat /proc/cmdline
2.reboot and append init=/bin/bash to the command line
  
Actual results:
1. shows the command line ends with console=tty0, that isn't specified
in the grub boot command line.  2. fails because bash doesn't like the
argument it is passed.

Expected results:
The extraneous argument should probably not be shown, and it would be
nice if 2. worked regardless of the presence of console= in the
default boot command line.

Additional info:
Adding `console=tty0 init=/bin/bash' works.

Comment 1 Dave Jones 2005-10-06 03:53:30 UTC
this got fixed quite a while back iirc.



Note You need to log in before you can comment on or make changes to this bug.