Bug 1360631 - ipa-backup is not keeping the /etc/tmpfiles.d/dirsrv-<instance>.conf
Summary: ipa-backup is not keeping the /etc/tmpfiles.d/dirsrv-<instance>.conf
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 08:03 UTC by German Parente
Modified: 2016-11-04 05:59 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:59:11 UTC


Attachments (Terms of Use)
console.log (15.29 KB, text/plain)
2016-09-01 11:42 UTC, Abhijeet Kasurde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description German Parente 2016-07-27 08:03:14 UTC
Description of problem:

since ipa-backup is storing all the conf files created by ipa/ns-slapd, this file should also be stored:

/etc/tmpfiles.d/dirsrv-<instance>.conf

this file allows daemon tmpfiles.d to re-create the dirs in volatile directories like /var/run or /var/lock

I had a case where customer after restore had issues to restart dirsrv and it was because this file was missing. Having said this, this file should always be present after a backup and restore. I cannot imagine how it has disappeared at customer side.

But if the policy is the store in files.tar all the files created by ipa/ns-slapd, this one should also be created.



Version-Release number of selected component (if applicable): ipa-server-4.2.0-15.el7_2.3.x86_64


How reproducible: always




Steps to Reproduce:
1. ipa-backup

Actual results:

tar tvf files.tar | grep tmpfiles.d
(no file)


Expected results:

tar tvf files.tar | grep tmpfiles.d
/etc/tmpfiles.d/dirsrv-<instance>.conf

Comment 2 Petr Vobornik 2016-08-03 12:00:18 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6165

Comment 3 Martin Bašti 2016-08-09 16:30:50 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/148e021ac11793d77561fd7ffd3d11ecc09d86a5

Comment 5 Abhijeet Kasurde 2016-09-01 11:42 UTC
Created attachment 1196768 [details]
console.log

Verified using IPA version ::
ipa-server-4.4.0-8.el7.x86_64

Marking BZ as verified.

Comment 7 errata-xmlrpc 2016-11-04 05:59:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.