Bug 1360647 - gfapi: deprecate the rdma support for management connections
Summary: gfapi: deprecate the rdma support for management connections
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact: Sudhir D
URL:
Whiteboard:
: 1360646 (view as bug list)
Depends On:
Blocks: 1376667
TreeView+ depends on / blocked
 
Reported: 2016-07-27 08:52 UTC by Prasanna Kumar Kalever
Modified: 2017-03-27 18:21 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1376667 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:21:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2016-07-27 08:52:52 UTC
Description of problem:
Improve glfs_set_volfile_server();

RDMA transport was never supported for management connection before, but glfs_set_volfile_server() allowed it and the gluster code silently fall back to tcp with out a warning, this gave a chance to people assume that mgmt connection supports rdma along with tcp and unix.

We need to deprecate the rdma support by stating to splash warning at the usage.

Also add better defense code on port and transport;


Version-Release number of selected component (if applicable):
mainline

Comment 1 Vijay Bellur 2016-07-27 09:06:59 UTC
REVIEW: http://review.gluster.org/15026 (gfapi: deprecate rdma support for management connections) posted (#1) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 2 Vijay Bellur 2016-07-27 15:45:27 UTC
COMMIT: http://review.gluster.org/15026 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 6e78a0dda9343d75674a12b7e1a1e8e59e17c78c
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Wed Jul 27 14:23:23 2016 +0530

    gfapi: deprecate rdma support for management connections
    
    RDMA transport was never supported for management connection before, but
    glfs_set_volfile_server() allowed rdma transport type due to lack of defense
    code and the glusterfs_mgmt_init() code silently fall back to tcp with out
    any warnings, this gave a chance for assumtions that mgmt connection also
    supports rdma along with tcp and unix.
    
    This patch deprecates the rdma support by warning at its usage.
    
    Change-Id: I0ad99d9851e05ff84ba4b6a3534a984bcc7e2ed7
    BUG: 1360647
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/15026
    Tested-by: Prasanna Kumar Kalever <pkalever@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Niels de Vos 2016-08-02 12:19:55 UTC
*** Bug 1360646 has been marked as a duplicate of this bug. ***

Comment 4 Shyamsundar 2017-03-27 18:21:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.