Bug 1360713 - python-xlib: Provide a Python 3 subpackage
Summary: python-xlib: Provide a Python 3 subpackage
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-xlib
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1361018 (view as bug list)
Depends On:
Blocks: PYTHON3 PY3PATCH-AVAILABLE
TreeView+ depends on / blocked
 
Reported: 2016-07-27 11:32 UTC by Dominika Krejčí
Modified: 2016-09-30 22:57 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-09-30 22:57:45 UTC


Attachments (Terms of Use)
Add Python 3 & version update (5.03 KB, patch)
2016-08-31 12:50 UTC, Dominika Krejčí
no flags Details | Diff

Description Dominika Krejčí 2016-07-27 11:32:41 UTC
Upstream, this software supports Python 3 [0]. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [1], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [2].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's OK to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 24 as well.


If you need more instructions, a guide for porting Python-based RPMs is
available at [3].
If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://github.com/python-xlib/python-xlib/releases/tag/0.16
[1] https://fedoraproject.org/wiki/Packaging:Python
[2] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
[3] http://python-rpm-porting.readthedocs.io/

Comment 1 Dominika Krejčí 2016-08-25 12:36:07 UTC
Hi Abdel,
how is it going? Do you need any help?

Comment 2 Dominika Krejčí 2016-08-31 12:50 UTC
Created attachment 1196359 [details]
Add Python 3 & version update

Hi Abdel,
here is the change needed to add Python 3 support and update the version. Could you please review it and do the update?

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=15450087

Also tested in Mock (fedora-23-x86_64, fedora-24-x86_64, fedora-25-x86_64, fedora-rawhide-x86_64, fedora-rawhide-i386).

Comment 3 Lumír Balhar 2016-09-12 10:15:26 UTC
Hello, Dominiko.

I tried to do a review of your patch but I think that your changes could have big impact on whole package and I also think that maintainer should look on non-working patches and decide what to do.

Comment 4 Orion Poplawski 2016-09-30 22:39:24 UTC
*** Bug 1361018 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.