Bug 1360774 - Dovecot fts_solr does not work with Solr >= 5.1
Summary: Dovecot fts_solr does not work with Solr >= 5.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dovecot
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: David Jež
URL:
Whiteboard:
Depends On:
Blocks: 1465906
TreeView+ depends on / blocked
 
Reported: 2016-07-27 12:51 UTC by acrow
Modified: 2018-10-30 10:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:54:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3182 None None None 2018-10-30 10:55:11 UTC

Description acrow 2016-07-27 12:51:32 UTC
Description of problem: Dovecot as provided by repos does not work fts_solr for solr versions >= 5.1. These versions of solr don't allow GET /select queries with Content-Type header set.

Version-Release number of selected component (if applicable):
2.2.10-5.el7

How reproducible:
Always

Steps to Reproduce:
1. Install and configure Solr 6
2. Install and configure dovecot with fts_solr plugin enabled
3. Perform a search

Actual results:
Search fails:
indexer-worker(xxx@example.com): Error: fts_solr: Lookup failed: Bad 
Request

Expected results:
Search succeeds

Additional info: Patch was posted to the dovecot mailing list on 2015-09-27.

--- dovecot-2.2.18/src/plugins/fts-solr/solr-connection.c    2015-05-13 17:14:45.000000000 +0300
+++ dovecot-2.2.18.patch/src/plugins/fts-solr/solr-connection.c    2015-09-27 19:47:40.363843359 +0300
@@ -432,7 +432,6 @@
                        solr_connection_select_response, conn);
     http_client_request_set_port(http_req, conn->http_port);
     http_client_request_set_ssl(http_req, conn->http_ssl);
-    http_client_request_add_header(http_req, "Content-Type", "text/xml");
     http_client_request_submit(http_req);

     conn->request_status = 0;

This was rolled in at 2.2.19 I believe.

Comment 6 errata-xmlrpc 2018-10-30 10:54:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3182


Note You need to log in before you can comment on or make changes to this bug.