Bug 1360792 - Migrating users doesn't update krbCanonicalName
Summary: Migrating users doesn't update krbCanonicalName
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-27 13:40 UTC by Martin Bašti
Modified: 2016-11-04 05:59 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:59:24 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Martin Bašti 2016-07-27 13:40:38 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/6101

Description of problem: [[BR]]
It is not possible to kinit as user after migrating users from one freeIPA server to another. The problem is that after migrating the krbCanonicalName stay unchanged (has old realm). krbPrincipalName is updated correctly.[[BR]]

Steps to reproduce: [[BR]]
1) Install two freeIPA servers[[BR]]
2) Create several users on the first one[[BR]]
3) Set passwords to these users[[BR]]
4) Use migrate-ds to migrate users to the second freeIPA[[BR]]
5) Try to login as migrated user[[BR]]
[[BR]]
Actual result: kinit user returns the following error:

{{{
kinit: Client 't2@FIPA2.EXAMPLE.COM' not found in Kerberos database while getting initial credentials
}}}

Comment 1 Martin Bašti 2016-08-01 15:14:47 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/1a04edd36bd95d0e6e8c43e742113b3e3cadfb6b

Comment 3 Nikhil Dehadrai 2016-09-19 12:07:50 UTC
IPA-server version: ipa-server-4.4.0-12.el7.x86_64

Verified the bug on the basis of following steps:
1. Verified that the users are migrated successfully (in my casefrom IPA1 to IPA2)
Run following command on IPA2 after creating 100 users on IPA1:

#ipa migrate-ds --user-container="cn=users,cn=accounts,dc=testrelm,dc=test" ldap://<IPA 1 Server hostname>

2. Verified that users are reflected correctly on both the servers:
# ldapsearch -h `hostname` -Y GSSAPI -b "cn=users,cn=accounts,dc=testrelm,dc=test"

3. Reset the migrated user password on IPA2 from UI. (In my case resetted the password for user test_100 to 'abcd')

4. On IPA2, run the following command 
# kinit test_100
Password for test_100@TESTRELM.TEST: 
Password expired.  You must change it now.
Enter new password: 
Enter it again: 

# klist
Ticket cache: KEYRING:persistent:0:0
Default principal: test_100@TESTRELM.TEST

Valid starting       Expires              Service principal
09/19/2016 07:59:09  09/20/2016 07:59:09  krbtgt/TESTRELM.TEST@TESTRELM.TEST

Thus on the basis of above observations marking status of bug to "VERIFIED".

Comment 5 errata-xmlrpc 2016-11-04 05:59:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.