Bug 136110 - Evolution can't Send/Recieve
Evolution can't Send/Recieve
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-17 19:15 EDT by louisgtwo
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 16:55:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description louisgtwo 2004-10-17 19:15:36 EDT
After opening evo and hitting Send/Recieve it hangs trying to get mail
from my ISP POP account. This is with rawhide current.

$ export CAMEL_VERBOSE_DEBUG=1
$ evolution

(evolution:6348): camel-WARNING **: Invalid root: '/home/louisg00/.
evolution/mail/local/Drafts.ibex.index'

(evolution:6348): camel-WARNING **: version: TEXT.000 (TEXT.000)

(evolution:6348): camel-WARNING **: block size: 1024 (1024) OK

(evolution:6348): camel-WARNING **: free: 0 (0 add size < 1024) OK

(evolution:6348): camel-WARNING **: last: 6144 (6144 and size: 1024) BAD

(evolution:6348): camel-WARNING **: flags: unSYNC

(evolution:6348): camel-WARNING **: Invalid root: '/home/louisg00/.
evolution/mail/local/Outbox.ibex.index'

(evolution:6348): camel-WARNING **: version: TEXT.000 (TEXT.000)

(evolution:6348): camel-WARNING **: block size: 1024 (1024) OK

(evolution:6348): camel-WARNING **: free: 0 (0 add size < 1024) OK

(evolution:6348): camel-WARNING **: last: 6144 (6144 and size: 1024) BAD

(evolution:6348): camel-WARNING **: flags: unSYNC

(evolution:6348): camel-WARNING **: Invalid root: '/home/louisg00/.
evolution/mail/local/Sent.ibex.index'

(evolution:6348): camel-WARNING **: version: TEXT.000 (TEXT.000)

(evolution:6348): camel-WARNING **: block size: 1024 (1024) OK

(evolution:6348): camel-WARNING **: free: 0 (0 add size < 1024) OK

(evolution:6348): camel-WARNING **: last: 6144 (6144 and size: 1024) BAD

(evolution:6348): camel-WARNING **: flags: unSYNC
Thread f6a04bb0 >
Get folder info(0x84598b8:vfolder:/home/louisg00/.evolution/mail/vfolder, 
'<null>') =
  uri: vfolder:/home/louisg00/.evolution/mail/vfolder#UNMATCHED
  full_name: UNMATCHED
  flags: 0000006a
< f6a04bb0 >
Thread f6a04bb0 >
Get folder info(0x84598b8:vfolder:/home/louisg00/.evolution/mail/vfolder, 
'<null>') =
  uri: vfolder:/home/louisg00/.evolution/mail/vfolder#UNMATCHED
  full_name: UNMATCHED
  flags: 0000006a
< f6a04bb0 >
Thread f6a04bb0 >
Get folder info(0x843af58:mbox:/home/louisg00/.evolution/mail/local,
'<null>') 
=  uri: mbox:/home/louisg00/.evolution/mail/local#Inbox
  full_name: Inbox
  flags: 00000008
  uri: mbox:/home/louisg00/.evolution/mail/local#Drafts
  full_name: Drafts
  flags: 00000008
  uri: mbox:/home/louisg00/.evolution/mail/local#Sent
  full_name: Sent
  flags: 00000008
  uri: mbox:/home/louisg00/.evolution/mail/local#Outbox
  full_name: Outbox
  flags: 00000008
  uri: mbox:/home/louisg00/.evolution/mail/local#Trash
  full_name: Trash
  flags: 000000f2
  uri: mbox:/home/louisg00/.evolution/mail/local#Junk
  full_name: Junk
  flags: 000000f2
< f6a04bb0 >
Thread f6a04bb0 >
Get folder info(0x843af58:mbox:/home/louisg00/.evolution/mail/local,
'<null>') 
=  uri: mbox:/home/louisg00/.evolution/mail/local#Inbox
  full_name: Inbox
  flags: 00000008
  uri: mbox:/home/louisg00/.evolution/mail/local#Drafts
  full_name: Drafts
  flags: 00000008
  uri: mbox:/home/louisg00/.evolution/mail/local#Sent
  full_name: Sent
  flags: 00000008
  uri: mbox:/home/louisg00/.evolution/mail/local#Outbox
  full_name: Outbox
  flags: 00000008
  uri: mbox:/home/louisg00/.evolution/mail/local#Trash
  full_name: Trash
  flags: 000000f2
  uri: mbox:/home/louisg00/.evolution/mail/local#Junk
  full_name: Junk
  flags: 000000f2
< f6a04bb0 >
Thread f5fdabb0 >
CamelFolder:get_message('Inbox', '3562') =
class: CamelMimeMessage
mime-type: text/plain; charset=iso-8859-1
content class: CamelDataWrapper
content mime-type: text/plain; charset=iso-8859-1
< f5fdabb0 >
POP3_STREAM_LINE(32): '+OK InterMail POP3 server ready.'
POP3_STREAM_WRITE(6):
CAPA

POP3_STREAM_LINE(27): '+OK Capability list follows'
Got + response
cmd_capa
POP3_STREAM_LINE(3): 'TOP'
POP3_STREAM_LINE(4): 'USER'
POP3_STREAM_LINE(10): 'RESP_CODES'
POP3_STREAM_LINE(10): 'PIPELINING'
POP3_STREAM_LINE(12): 'EXPIRE NEVER'
POP3_STREAM_LINE(4): 'UIDL'
POP3_STREAM_LINE(72): 'IMPLEMENTATION Openwave Email vM.5.01.06.10
201-253-122-
130-110-20040306'
POP3_STREAM_LINE(END)
POP3_STREAM_WRITE(15):
USER louisg00

POP3_STREAM_WRITE(15):
PASS xxxxxxxx
POP3_STREAM_LINE(28): '+OK please send PASS command'
Got + response
POP3_STREAM_LINE(28): '+OK louisg00 is welcome here'
Got + response
POP3_STREAM_WRITE(6):
CAPA

POP3_STREAM_LINE(27): '+OK Capability list follows'
Got + response
cmd_capa
POP3_STREAM_LINE(3): 'TOP'
POP3_STREAM_LINE(4): 'USER'
POP3_STREAM_LINE(10): 'RESP_CODES'
POP3_STREAM_LINE(10): 'PIPELINING'
POP3_STREAM_LINE(12): 'EXPIRE NEVER'
POP3_STREAM_LINE(4): 'UIDL'
POP3_STREAM_LINE(72): 'IMPLEMENTATION Openwave Email vM.5.01.06.10
201-253-122-
130-110-20040306'
POP3_STREAM_LINE(END)
POP3_STREAM_WRITE(6):
LIST

POP3_STREAM_WRITE(6):
UIDL

POP3_STREAM_LINE(14): '+OK 3 messages'
Got + response
POP3_STREAM_LINE(6): '1 3750'
POP3_STREAM_LINE(6): '2 3623'
POP3_STREAM_LINE(6): '3 1610'
POP3_STREAM_LINE(END)
POP3_STREAM_LINE(14): '+OK 3 messages'
Got + response
POP3_STREAM_LINE(41): '1 <1097973346 4378 2 camel home gnome no>'
POP3_STREAM_LINE(41): '2 <1097973433 4378 5 camel home gnome no>'
POP3_STREAM_LINE(43): '3 <1430611617 20041017164204 jaydemail com>'
POP3_STREAM_LINE(END)
POP3_STREAM_WRITE(8):
RETR 1

POP3_STREAM_WRITE(8):
RETR 2

POP3_STREAM_WRITE(8):
RETR 3

CamelException.setv(0x8738d18, 2, 'Cannot get message <1097973346.4378.2.
camel home gnome no>: Input/output error')
POP3_STREAM_WRITE(6):
QUIT

loading error file /usr/share/evolution/2.0/errors/filter-errors.xml
loading error file
/usr/share/evolution/2.0/errors/mail-composer-errors.xml
loading error file /usr/share/evolution/2.0/errors/addressbook-errors.xml
loading error file /usr/share/evolution/2.0/errors/e-system-errors.xml
loading error file /usr/share/evolution/2.0/errors/shell-errors.xml
loading error file /usr/share/evolution/2.0/errors/mail-errors.xml
loading error file /usr/share/evolution/2.0/errors/calendar-errors.xml
Comment 1 louisgtwo 2004-10-17 21:30:55 EDT
It seems this is a kernel issue. kernel-2.6.8-1.624 causes this
problem. Went back to kernel-2.6.8-1.610 and evo is working fine.
Comment 2 Alex Roman 2004-10-20 15:55:51 EDT
I can confirm this bug and it's "fix". Reverting to the -610 kernel
indeed solves the problem. I wonder what the problem is... :/
Comment 3 louisgtwo 2004-10-20 16:55:37 EDT
fixed in kernel-2.6.9-1.639

Note You need to log in before you can comment on or make changes to this bug.