Bug 1361157 - Chromium "Aw, Snap" pages
Summary: Chromium "Aw, Snap" pages
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 1366894 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-28 12:15 UTC by eddy02
Modified: 2016-10-21 15:51 UTC (History)
4 users (show)

Fixed In Version: chromium-52.0.2743.116-9.fc24 chromium-52.0.2743.116-10.fc25 chromium-52.0.2743.116-10.fc23 chromium-53.0.2785.143-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-21 15:51:52 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description eddy02 2016-07-28 12:15:23 UTC
Got "Aw, Snap" pages with chromium early builds (fc25 and fc26).
No issue when disabling sandboxing with  the --no-sandbox options.
Seems to be specific to fc25 and fc26.

I had the same issue with the copr builds.
This bug seems happening after a rawhide change a few months ago (march).
Since no success even after trying rebuild other versions (update and dev).

Latest Qtwebengine (chromium base) seems to have the same issue (blank and white pages).


Received signal 4 ILL_ILLOPN 7f10c7121f90
#0 0x7f10dc5b2b7e base::debug::StackTrace::StackTrace()
#1 0x7f10dc5b2f6b <unknown>
#2 0x7f10cb689540 <unknown>
#3 0x7f10c7121f90 WTF::decommitSystemPages()
#4 0x7f10dbcd47e0 <unknown>
#5 0x7f10dbcd5003 <unknown>
#6 0x7f10dbcd2ba6 blink::NormalPageArena::allocatePage()
#7 0x7f10dbcd3550 blink::NormalPageArena::outOfLineAllocate()
#8 0x7f10db6cd59d blink::ChromeClientImpl::create()
#9 0x7f10db785410 blink::WebViewImpl::WebViewImpl()
#10 0x7f10db7861a0 blink::WebViewImpl::create()
#11 0x7f10d97e8dfc content::RenderViewImpl::Initialize()
#12 0x7f10d97ebcf1 content::RenderViewImpl::Create()
#13 0x7f10d97dda26 content::RenderThreadImpl::OnControlMessageReceived()
#14 0x7f10d95e3ca2 <unknown>
#15 0x7f10d4b016e4 IPC::ChannelProxy::Context::OnDispatchMessage()
#16 0x7f10dc5b4759 base::debug::TaskAnnotator::RunTask()
#17 0x7f10c1752a71 scheduler::TaskQueueManager::ProcessTaskFromWorkQueue()
#18 0x7f10c1753064 scheduler::TaskQueueManager::DoWork()
#19 0x7f10c175093b <unknown>
#20 0x7f10dc5b4759 base::debug::TaskAnnotator::RunTask()
#21 0x7f10dc5d8401 base::MessageLoop::RunTask()
#22 0x7f10dc5d8e7d base::MessageLoop::DeferOrRunPendingTask()
#23 0x7f10dc5d9159 base::MessageLoop::DoWork()
#24 0x7f10dc5dabd9 base::MessagePumpDefault::Run()
#25 0x7f10dc5f7db8 base::RunLoop::Run()
#26 0x7f10dc5d7345 base::MessageLoop::Run()
#27 0x7f10d98035d0 <unknown>
#28 0x7f10d91e95fe <unknown>
#29 0x7f10d91e9b08 <unknown>
#30 0x7f10d91e8cc9 content::ContentMain()
#31 0x55b1378fa75a ChromeMain
#32 0x7f10c7c0a401 __libc_start_main
#33 0x55b1378fa60a _start
  r8: 0000000000000000  r9: 0000000000000000 r10: 0000000000000000 r11: 0000000000000206
 r12: 000009725e618210 r13: 0000000000000004 r14: 000009725e618228 r15: 0000000000000000
  di: 00000f1c50a81000  si: 000000000001e000  bp: 000009725e664000  bx: 000009725e618230
  dx: 0000000000000008  ax: ffffffffffffffff  cx: ffffffffffffff60  sp: 00007ffc9286fe50
  ip: 00007f10c7121f90 efl: 0000000000010286 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000006 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]

Comment 1 Tom "spot" Callaway 2016-07-28 14:15:37 UTC
Which build of chromium are you trying specifically?

Comment 2 eddy02 2016-07-29 05:27:43 UTC
Tried chromium-52.0.2743.82-4.fc25 then update to chromium-52.0.2743.82-5.fc26 

Before i was using the copr lantw44/chromium builds.
This issue remains since chromium-49.0.2623.108 after a rawhide update.
Not sure but after glibc-2.23.90 upgrade.

Comment 3 Tom "spot" Callaway 2016-07-29 12:48:56 UTC
Is this on every page? Please test on the -9 builds. If this is a glibc or gcc issue, it's probably going to have the same problem, but lets start from there.

I don't currently have a f25/f26 VM, but thats remedied easily enough.

Comment 4 eddy02 2016-07-29 13:44:00 UTC
No success with -9 builds, issue on every page unless with --no-sandbox or --disable-seccomp-filter-sandbox option.

Hope to be useful,found on chromium devel lists: 

"Aw, snap!" for all tabs unless --no-sandbox or --disable-seccomp-filter-sandbox

Update: After some heroic config bisecting by pixelmaze (thanks!), we think we understand the cause. On kernels compiled with CONFIG_COMPAT_VDSO=y (an option which disables vdso on x86-32), we crash because we do not register a restorer function (which glibc's sigaction does), and the one in vdso is not available.

Comment 5 Tom "spot" Callaway 2016-07-29 14:08:41 UTC
But Fedora kernels have:

# CONFIG_COMPAT_VDSO is not set

... so I don't think that's it. Are you using a Fedora kernel?

Comment 6 Yanko Kaneti 2016-07-29 14:10:33 UTC
I am on rawhide, with the same problem.
chromium-52.0.2743.82-9.fc26.x86_64
kernel-4.7.0-0.rc7.git4.2.fc25.x86_64
glibc-2.23.90-30.fc25.x86_64

Comment 7 Viorel Tabara 2016-08-11 23:17:21 UTC
Same here, just upgraded to F25 and running:

[root@omiday selinux]# rpm -qa --last "*chromium*" kernel glibc 
chromium-52.0.2743.116-1.fc25.x86_64          Thu 11 Aug 2016 02:42:23 PM MDT
chromium-libs-52.0.2743.116-1.fc25.x86_64     Thu 11 Aug 2016 02:42:16 PM MDT
chromium-libs-media-52.0.2743.116-1.fc25.x86_64 Thu 11 Aug 2016 02:42:09 PM MDT
glibc-2.24-1.fc25.i686                        Thu 11 Aug 2016 02:03:41 PM MDT
kernel-4.8.0-0.rc1.git3.1.fc25.x86_64         Thu 11 Aug 2016 02:02:11 PM MDT
glibc-2.24-1.fc25.x86_64                      Thu 11 Aug 2016 01:56:37 PM MDT
kernel-4.6.5-300.fc24.x86_64                  Thu 04 Aug 2016 08:06:41 AM MDT
kernel-4.6.4-301.fc24.x86_64                  Mon 25 Jul 2016 09:20:17 PM MDT

Comment 8 eddy02 2016-08-14 11:26:43 UTC
Kevin Kofler (qtwebengine maintainer) commits a patch for qtwebengine glibc2.24 crash.

Patching and building chromium with a modified piece of this patch solve the issue.
Chromium is running well now.

The patch:

--- /chromium/third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp	2016-08-03 21:02:37.000000000 +0200
+++ /chromium/third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp	2016-08-14 10:59:51.395354850 +0200
@@ -41,6 +41,11 @@
 #include <errno.h>
 #include <sys/mman.h>
 
+#if OS(LINUX) && defined(MADV_FREE)
+// Added in Linux 4.5, but we don't want to depend on 4.5 at runtime
+#undef MADV_FREE
+#endif
+
 #ifndef MADV_FREE
 #define MADV_FREE MADV_DONTNEED
 #endif


Sorry for my english.

Comment 9 Tom "spot" Callaway 2016-08-15 17:10:23 UTC
*** Bug 1366894 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2016-08-17 17:34:50 UTC
chromium-52.0.2743.116-9.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-19c0d6b4b2

Comment 11 Fedora Update System 2016-08-17 17:35:13 UTC
chromium-52.0.2743.116-9.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3431daeaf0

Comment 12 Fedora Update System 2016-08-17 17:35:32 UTC
chromium-52.0.2743.116-9.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a35f3eeea

Comment 13 Fedora Update System 2016-08-17 17:35:53 UTC
chromium-52.0.2743.116-9.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-95d9b62ed3

Comment 14 Fedora Update System 2016-08-17 19:52:00 UTC
chromium-52.0.2743.116-9.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-95d9b62ed3

Comment 15 Fedora Update System 2016-08-18 01:50:11 UTC
chromium-52.0.2743.116-9.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a35f3eeea

Comment 16 Fedora Update System 2016-08-18 01:51:11 UTC
chromium-52.0.2743.116-9.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3431daeaf0

Comment 17 Fedora Update System 2016-08-18 04:18:30 UTC
chromium-52.0.2743.116-9.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-19c0d6b4b2

Comment 18 Fedora Update System 2016-08-25 13:54:34 UTC
chromium-52.0.2743.116-9.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2016-08-26 13:33:00 UTC
chromium-52.0.2743.116-10.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2a0c80295c

Comment 20 Fedora Update System 2016-08-26 13:33:37 UTC
chromium-52.0.2743.116-10.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3a8d9311f8

Comment 21 Fedora Update System 2016-08-27 12:53:20 UTC
chromium-52.0.2743.116-10.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2a0c80295c

Comment 22 Fedora Update System 2016-08-27 22:21:49 UTC
chromium-52.0.2743.116-10.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3a8d9311f8

Comment 23 Fedora Update System 2016-08-29 19:26:06 UTC
chromium-52.0.2743.116-11.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e82affa05e

Comment 24 Fedora Update System 2016-08-31 13:49:53 UTC
chromium-52.0.2743.116-11.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e82affa05e

Comment 25 Fedora Update System 2016-08-31 16:28:43 UTC
chromium-52.0.2743.116-10.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2016-09-09 16:54:53 UTC
chromium-52.0.2743.116-10.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2016-09-09 19:08:02 UTC
chromium-53.0.2785.101-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-6d70ae9a57

Comment 28 Fedora Update System 2016-09-10 05:48:50 UTC
chromium-53.0.2785.101-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-6d70ae9a57

Comment 29 Fedora Update System 2016-09-14 19:28:47 UTC
chromium-53.0.2785.113-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-449d647265

Comment 30 Fedora Update System 2016-09-15 23:52:15 UTC
chromium-53.0.2785.113-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-449d647265

Comment 31 Fedora Update System 2016-09-28 16:19:51 UTC
chromium-53.0.2785.116-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-bf5b9b3332

Comment 32 Fedora Update System 2016-10-04 13:19:46 UTC
chromium-53.0.2785.143-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-387d58ef27

Comment 33 Fedora Update System 2016-10-21 15:51:52 UTC
chromium-53.0.2785.143-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.