Bug 136121 - VNC terminal service prototype conflicts with Native X Desktop
VNC terminal service prototype conflicts with Native X Desktop
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2004-10-17 22:15 EDT by Emerson House
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-28 10:31:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Emerson House 2004-10-17 22:15:51 EDT
Description of problem: Terminal Services Prototype fails to work when
upgrading system that has vnc configured to natively remote the :0

Version-Release number of selected component (if applicable):

How reproducible:
Always on this system.

Steps to Reproduce:
1.Install FC2, Configure VNC with ReaLNVC Native X Desktop support for
 :0 desktop.  I.e. load vnc module in xorg.conf.  Sucessful remote
access to :0.  Upgrade vnc for FC2 from updates-released.
2.Upgrade FC2 to FC3T3.  VNC operates as in FC2 with support for :0,
but no support for additional logins.
Actual results:
Native X Desktop support for :0 works and additional destops can be
started manually on different ports, but connection to port 5900 only
connects to :0

Expected results:
VNC connection to port 5900 should bring up logon screen.  Logging in
as different users should connect to differnent displays.

Additional info:
There really isn't any documentation on how the terminal services
prototype is supposed to work, although starting new displays is a
desireable feature.  I can't check anything in the configuration
because there isn't any explanation or how-to about how it should
work.  But there are probably other people who have the Native X
Desktop support configured and they will probably all try to get the
terminal services prototype to work so you should include some kind of
description of how to reconcile the two or at least warn people that
they are incompatable.
Comment 1 Tim Waugh 2004-10-18 03:57:23 EDT
Mark, any idea what's going on with that?
Comment 2 Mark McLoughlin 2004-10-28 10:31:23 EDT
Yeah, I think its probably just that the vnc module is already using
that port. You can configure the port GDM uses for VNC in

Its best to just discuss this stuff on fedora-desktop rather than
logging bugs, though. Closing as NOTABUG

Comment 3 Emerson House 2004-10-28 11:28:18 EDT
Gee, actually that did occur to me and I tried removing the vnc
module.  With the module removed there was no vnc conectivity.  I also
thought gdm.conf was a reasonable place to look for some kind of
configuration settings, but there is nothing in my gdm.conf that has
anything to do with vnc or even ports.  I did check that DiallowTCP
setting was off.  

Again if there was any kind of explanation how this was going to work
I would check my configuration but there is nothing that gives any
kind of explanation.

My gdm.conf was updated by the new installation and has the same size
and time-stamp as factory-gdm.conf.
Comment 4 Emerson House 2004-12-19 00:20:39 EST
Mystery Solved!  

Fedora 3 Release Notes imply that this functionality is installed as
part of the the Fedora 3 base distribution.  In fact this
functionallity is part of the fedora-extras package vnc-ltcs-config
package.  Installation of this package establishes this functionality
and does not even need the VNC Native X Desktop support for :0 to be
removed, although it probably should. 

I really think the Fedora 3 release notes are misleading about this

Note You need to log in before you can comment on or make changes to this bug.