Bug 136132 - There is no /proc/kallsyms in RHEL4β1
There is no /proc/kallsyms in RHEL4β1
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 03:09 EDT by L3support
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 05:21:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-10-18 03:09:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
   There is no /proc/kallsyms in RHEL4.
It embarrasses very much if this information cannot be 
referred when the  third party driver cannot build it 
in the kernel due to the symbol disagreement.

   The version symbol of the function was able to be referred to 
by referring to /proc/ksyms in RHEL2.1 and RHEL3. 
We expected that /proc/kallsyms existed in kernel-2.6.

  Thank you for your consideration.

Version-Release number of selected component (if applicable):
kernel-2.6

How reproducible:
Always

Steps to Reproduce:
1.See /proc/kallsyms directory by using ls or cd command.

    

Actual Results:  Refer the description of problem

Expected Results:  We can use /proc/kallsyms in RHEL4β1.

Additional info:

Business Impact: Our developing product is influenced by this problem.
Comment 1 Bill Nottingham 2004-10-18 12:50:23 EDT
/proc/kallsyms is not present in the 2.6 kernel series. There is
/boot/System.map-<version>, which may be useful to you.
Comment 2 L3support 2004-10-19 00:40:45 EDT
 We appreciate to your quick reply.
But our problem hasn't been solved yet.
Firstly, what we really want to know is the reason
that why there is no /proc/kallsyms in RHEL 4 Beta 1.
Normally, /proc/kallsyms is existed in other distributions 
of the 2.6 kernel series. Moreover there is an actual fact that
/proc/ksyms is existed in RHEL 3 and RHEL 2.1 .
That's why we think /proc/kallsyms should be existed 
in the 2.6 kernel series(RHEL 4 Beta 1).
So please tell us the reason why there is no /proc/kallsyms.
Don't you plan to make /proc/kallsyms in your 2.6 kernel in future?

 As you told us there are similar informations in 
/boot/System.map-<version>. Unfortunately there is 
no information about the driver in /boot/System.map-<version>
which is appeared in /proc/kallsyms or /proc/ksyms.
To develop our new software we need to refer this information.
Please tell us if there is another way to refer this information.
Comment 3 L3support 2004-10-24 22:28:30 EDT
 Hello. From our last questions It's passed for a week now.
Have you got any difficulties to answer our questions?
If you so, please tell us what is the difficulty.
We are looking forward to hearing from you.
Thank you.
Comment 4 L3support 2004-10-28 06:36:55 EDT
 It's passing nearlly two weeks from first time we asked you this
incident. Please give us your response whether you are still working 
with this or not. We are waiting for your answer which we asked for 
on 2004-10-19 00:40. If you're having a problem to answer something 
like you can't understand what we're saying. Please ask us, OK??

Thank you.
Comment 5 L3support 2004-11-11 07:51:35 EST
 We are waiting for long long time by now.
We asked you that there is no symbol about drivers
in /boot/System.map-<version> which you told us before.
As we told you that we need the symbol about drivers 
as we could see in /proc/ksyms of RHEL3.

 We think we haven't got an enough answer from you.
Therefore we asked you again why there is no /proc/ksyms in RHEL4. 
And tell us if there is any plan that /proc/ksyms comes back in 
latest RHEL4 or show us how to refer the symbol about 
drivers excepting /boot/System.map-<version>.
Comment 6 Dave Jones 2004-11-20 02:07:31 EST
reeanbled in current kernels.
Comment 7 Jay Turner 2004-11-23 05:21:31 EST
Fix confirmed with 2.6.9-1.751_ELsmp.

Note You need to log in before you can comment on or make changes to this bug.