Bug 136136 - rhn-applet-(t,g)ui pythonpath incorrect
rhn-applet-(t,g)ui pythonpath incorrect
Status: CLOSED DUPLICATE of bug 135735
Product: Fedora
Classification: Fedora
Component: rhn-applet (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 03:53 EDT by Folke Lemaitre
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Folke Lemaitre 2004-10-18 03:53:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041016
Firefox/0.10.1

Description of problem:
When running rhn-applet-tui or rhn-applet-gui, the program exits with:
Traceback (most recent call last):
  File "/usr/bin/rhn-applet-tui", line 21, in ?
    from rhn_applet_model import rhnAppletModelTUI
  File "/usr/share/rhn/rhn_applet/rhn_applet_model.py", line 24, in ?
    from rhn_sources import getSources, changedSources
  File "/usr/share/rhn/rhn_applet/rhn_sources.py", line 8, in ?
    from sourcesConfig import SourcesConfigFile
  File "/usr/share/rhn/up2date_client/sourcesConfig.py", line 17, in ?
    import up2dateUtils
  File "/usr/share/rhn/up2date_client/up2dateUtils.py", line 17, in ?
    import rpmUtils
  File "/usr/lib/python2.3/site-packages/rpmUtils/__init__.py", line
6, in ?
    import oldUtils
  File "/usr/lib/python2.3/site-packages/rpmUtils/oldUtils.py", line
8, in ?
    from i18n import _
ImportError: No module named i18n


As a workaround and probably also as a fix:
Add the followin to rhn-applet-(g,t)ui right after the first 
sys.path.append:
sys.path.append("/usr/share/yum-cli")




Version-Release number of selected component (if applicable):
rhn-applet-2.1.15-2

How reproducible:
Always

Steps to Reproduce:
1. Run rhn-applet-tui or rhn-applet-gui


Actual Results:  python import error on i18n

Expected Results:  No import error

Additional info:
Comment 1 Bill Nottingham 2004-10-18 12:50:53 EDT

*** This bug has been marked as a duplicate of 135735 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.