Bug 136140 - adjustment to new stat64 interface in 2.6
adjustment to new stat64 interface in 2.6
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ia32el (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 05:59 EDT by Yoav Zach
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 12:55:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
adjust to new interface of stat64 in kernel 2.6 (3.16 KB, patch)
2004-10-18 06:01 EDT, Yoav Zach
no flags Details | Diff

  None (edit)
Description Yoav Zach 2004-10-18 05:59:11 EDT
Description of problem:
The execution layer is not aware of the full 32 bit device numbers, 
and it discards the upper 12 bits of the minor number and 4 bits of 
the major number when doing stat calls. (Now we have 20bit minors/12 
bit majors in the 2.6 kernel)


Version-Release number of selected component (if applicable):
5079

How reproducible:
consistently


Steps to Reproduce:
create a block device
 # mknod /tmp/dev b 1 1000
copy an IA-32 stat program to a IPF system and do
 #stat32 /tmp/dev  --format=%T
  
Actual results:
e8

Expected results:
3e8

Additional info:
Comment 1 Yoav Zach 2004-10-18 06:01:13 EDT
Created attachment 105367 [details]
adjust to new interface of stat64 in kernel 2.6
Comment 2 Jakub Jelinek 2004-10-21 15:45:32 EDT
Patch is in ia32el-1.1-6.
Comment 3 Jay Turner 2005-01-13 12:55:28 EST
Closing out.  Please reopen if the problem is still present with recent code.

Note You need to log in before you can comment on or make changes to this bug.