Bug 1361404 - Google Music not working... no sound, selections skipping
Summary: Google Music not working... no sound, selections skipping
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: 24
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-29 03:22 UTC by Gerald Cox
Modified: 2017-08-08 16:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-08 16:01:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Gerald Cox 2016-07-29 03:22:33 UTC
Description of problem:
When attempting to use Google Music, no sound; also keep getting messages that selections are skipped.

Version-Release number of selected component (if applicable):
chromium-52.0.2743.82-9.fc24.x86_64


How reproducible:
Open Google Music, attempt to play songs.


Additional info:

Google music does require pepperflash to function.  I have linked to what chrome is using, and tested via:  chrome://flash

Please also note that qupzilla automatically utilizes pepperflash if installed - and Google Music works flawlessly with that browser.

Since one needs to install pepperflash to get Google Music to work, I don't consider this issue a blocker to releasing Chromium... however, people are going to want to utilize this functionality, so it should be fixed - especially since qupzilla supports it with no issues.

Comment 1 Tom "spot" Callaway 2016-07-29 12:47:27 UTC
I've never used Google Music before, but I took these steps to try to reproduce on my Fedora 24 system:

# make the home for the PepperFlash bits

  sudo mkdir /usr/lib64/chromium-browser/PepperFlash
 
# copy the PepperFlash bits from google-chrome-stable (52.0.2743.82)

  sudo cp -a /opt/google/chrome/PepperFlash/* \ 
  /usr/lib64/chromium-browser/PepperFlash/

# Kill off all the running chromium instances and restart chromium.
# confirm that chromium has flash via chrome://flash

#####

Sure enough, the first time I opened Google Play Music (I picked a random radio stream) didn't want to play, it skips through tracks.

(I picked "Today's Pop Hits" just because it was there.)

Then, I went to test other sites and I was able to get working sound out of the 52 PepperFlash in other places, like:

http://musicofnature.org/songsofinsects/flashtest/index.html
http://www.dhs.state.il.us/accessibility/tests/flash/video.html
http://pandora.com

Then I went back to confirm that Google Music wasn't working... and it started working fine.

You might load up chrome://media-internals/ in another tab while Google Music is running and see if the Audio tab sheds any light on things.

I tried a few times to get the bug to reproduce, and the best I could get it to do is very occasionally refuse to play a track... I'm guessing there might be a timing bug somewhere in PepperFlash, if that's the case, its definitely not something I can fix (nor really debug).

I'll leave this open for now, so you can poke this a bit harder and see if you can tease out anything else interesting.

Comment 2 Gerald Cox 2016-07-29 17:37:08 UTC
Thanks for taking the time to investigate Tom.  I did basically the same thing you did but am using symbolic links back to Chrome.  You're right, the links you supply play fine, but after trying and going back to Google Music, I got the same behavior... no sound.  When looking at the audio tab, the one thing I did notice was that the link you supplied is using an ogg file.  Google Music uses MP3?  Could this be it?  

That begs the question though on how qupzilla appears to be working fine.  It isn't packaged (AFAIK) with mp3.  So maybe that is just a red herring.

Comment 3 Tom "spot" Callaway 2016-07-29 17:40:58 UTC
I don't know what Google Music is using, but as it seems to be going through pepperflash, it shouldn't matter.

The fact that it works on my end leads me to suspect something specific on your end. Do you have any other addons? The only other thing I have in chromium is widevine. Maybe that's needed?

Comment 4 Gerald Cox 2016-07-29 20:01:10 UTC
I don't think widevine is required, since it is working fine on qupzilla, but did it anyway... still doesn't work.  I also tried in incognito mode and still doesn't work.  As far as working on your end... didn't you say that you still have songs refusing to play?  I haven't seen this at on on Chrome or qupzilla and I use Google Music all the time... maybe once more people install this we'll get more feedback...I realize it's still relatively new.

Comment 5 Gerald Cox 2016-07-29 20:27:58 UTC
I just installed chromium from copr churchyard/chromium-russianfedora
and did a ln -s /opt/google/chrome/PepperFlash/* . to the /lib64/chromium/pepper directory.  Google music is working perfectly - so, since it is working with Chrome, russianfedora and qupzilla... there has to be something unique to your implementation which is causing the problem...

Comment 6 Tom "spot" Callaway 2016-07-29 21:08:13 UTC
I have no idea what revision of blink that qupzilla is based on, but it is _not_ chromium. Nor do I get to look closely at how Chrome is put together because we _know_ it has proprietary bits inside it. Comparing Chrome to Chromium is useful in this as a data point, because they should be using the same pepperflash.

The "russianfedora" chromium in that copr is 50.0.2661.75, built against fedora 23. That's two major versions back. Any number of things could be different there.
I'll still look at their patches to see if any of them are worth adding. One difference is that they are using the full ffmpegsumo stack, which we can't do in Fedora. It's possible that the pepperflash plugin is using ffmpegsumo for decoding.

Comment 7 Gerald Cox 2016-07-29 21:16:17 UTC
Just tested with vivaldi (which I believe is using the chrome engine) and the symptoms there are exactly the same as in your Chromium... I'll pursue with them and see if they might be able to offer a clue as to what is happening.

Comment 8 Kevin Kofler 2016-08-07 21:16:34 UTC
QupZilla is not directly based on Blink, it uses QtWebEngine, which is based on Blink. So you cannot map a QupZilla version to a Chromium version, you can only map a QtWebEngine version to a Chromium version.

QtWebEngine 5.7.x (current in F25 and Rawhide) is based on Chromium 49.
QtWebEngine 5.6.x (current in F23 and F24) is based on Chromium 45.
Both have security fixes and a few other bugfixes backported.
The current QupZilla 2.0.1 supports both QtWebEngine 5.6 and 5.7.

Comment 9 Gerald Cox 2016-08-07 21:56:16 UTC
The vivaldi problem is now resolved in their latest snapshot:
https://vivaldi.net/en-US/teamblog/139-snapshot-1-3-551-17-further-bugfixing

which is based on chromium:   52.0.2743.117

Whether that makes a difference or not, I'm not sure, since when I tested this with Chrome, it was at the same level as Chromium.  My Chrome now is at:  52.0.2743.116

Apparently it is under:  VB-14762 for vivaldi, but good luck trying to find it.  Doesn't look like they have a public bug tracking system yet. (At least I can't find it).  Doesn't look like they were able to reproduce or isolate either - but again, it appears fixed in their latest release.  

Something is definitely going on though, because I can reproduce at will with Chromium and Vivaldi 1.2; Vivaldi snapshot is golden... problem not reproducible there.

Comment 10 Gerald Cox 2016-08-08 00:03:08 UTC
Just for a bit of a sanity test, I installed Chromium on my laptop.  Same exact results - so doubtful it's some kind of hardware issue.

Comment 11 Rex Dieter 2016-08-11 14:16:50 UTC
After copying PepperFlash and restarting chromium (latest in -testing at the moment), both facebook video and google music "just work" for me.

Comment 12 Gerald Cox 2016-08-12 00:28:36 UTC
Just tested on both my desktop and laptop with ~.116 and same thing.  No sound, and when it does play a selection it stops after about 15 seconds and then jumps to the next song.  Works in Chrome, works in QupZilla, works in the new Vivaldi snapshot... but unfortunately not able to get it going in chromium.  I thought that possibly some of the other stuff from previous installs was getting in way, so did a search on Chromium and deleted everything and reinstalled... but that didn't help.  

As I mentioned above, Vivaldi apparently couldn't reproduce the issue, but for me at least its gone with their .117 snapshot.  

I posted on Twitter about this to people who were also having the vivaldi issue, so hopefully someone can offer a clue as to the issue.

Comment 13 Gerald Cox 2016-08-12 20:13:43 UTC
Just a quick update, I did find this issue:

https://productforums.google.com/forum/#!topic/play/E8cS7pQ6ets;context-place=topicsearchin/play/category$3Awindows

Looks like this issue has been recurring for several years now, but I've yet to be able to find a definitive cause.  Will keep looking... and if anyone else finds something, please post here.

Comment 14 Gerald Cox 2016-08-12 20:20:48 UTC
Here is the link I found where the vivaldi users were encountering the issue, which was corrected in the latest snapshot... but no one seems to know why:
https://vivaldi.net/en-US/forum/vivaldi-browser/9009-google-play-music-displays-unable-to-reach-google-play-skipping-current-song

Comment 15 David Moreau Simard 2016-08-15 16:05:39 UTC
Vivaldi released a new stable package recently:
vivaldi-stable-1.3.551.30-1.x86_64

This latest update seems to have fixed /some/ things -- for example Google Play Music works once more.

Some other content is still broken (and I guess out of scope of this bug) but in case if relevant, when comparing with Chrome version:
google-chrome-stable-52.0.2743.116-1.x86_64

This works in Chrome but not in Vivaldi:
- https://twitter.com/dmsimard/status/761600452865695744

In Chrome, all three videos on http://www.quirksmode.org/html5/tests/video.html are working while in Vivaldi the first one isn't.

Comment 16 Stanislav Graf 2016-10-08 12:13:10 UTC
For me Google Play Music works on Chrome but not on Chromium under Fedora 25 (it didn't work from the start of official Fedora Chromium build). I tried adding both PepperFlash and Widevine to Chromium, I see them on plugins page, I can play flash videos, but with no luck on Google Play Music - no tracks could be played. At the same time, on the same machine, if I install Chrome and try it, all works.

I also reviewed above links to various discussions with no luck on fixing this.

Comment 17 Tom "spot" Callaway 2016-10-10 16:32:05 UTC
I can't help but wonder if this is a codec/transcoding issue. Can someone here propose a very specific google music stream that we can all test against?

The biggest difference between Google Chrome and Chromium is the media codecs it supports (and for which we cannot enable in Fedora Chromium because of legal issues).

Comment 18 Gerald Cox 2016-10-11 15:01:59 UTC
Correct me if I'm wrong but I don't believe that the free accounts have the capability to do that.  I've been doing searches and this problem has also been reported on Chrome, Android, Firefox you name it.  I also read where people on free accounts apparently can use html5 but those who actually pay for it are still using flash (go figure).  I posted above that this had been an issue in Vivaldi, and has been fixed - but no one seems to know (or wants to bother to explain) the issue.  What might be the best thing would be to open a ticket with Chromium.  If may well be that Google is in the middle of trying to get rid of flash and they are breaking things along the way because they aren't clearly communicating what they are doing.  If you want me to do it and post the ticket here I can do that... but please chime in, because you're the SME.

Comment 19 Tom "spot" Callaway 2016-10-11 15:11:13 UTC
Please open a bug with Google and put the link back here. I'm not sure where to even begin troubleshooting this with the information I have right now, and I don't have a paid Google Music account.

Comment 20 Gerald Cox 2016-10-11 15:31:43 UTC
Tom, Will do... here is something else: After getting the "Can't play...skipping" message several times, one final message is displayed:  "Can't reach Google Play
Reload the page and try again." That indicated to me that this wasn't a codec issue.  Then I remembered reading that there was an apparent difference (comment 18) in the way Google is treating paid vs free accounts... so I created a new account and yes, it works fine.  So basically I think that my last comment above is what is happening.... Google is in the middle of trying to get rid of flash and they are breaking things along the way.  There is absolutely no reason why they should be requiring their PAID customers to use Chrome and breaking everything else.  They are clearly doing something bizarre.

Comment 21 Stanislav Graf 2016-10-11 15:35:28 UTC
(In reply to Gerald Cox from comment #20)

My experience matches that too, I have paid account. Thanks for noticing this difference.

Comment 22 Gerald Cox 2016-10-11 15:42:15 UTC
Here is the chromium bug:
https://bugs.chromium.org/p/chromium/issues/detail?id=654774

Comment 23 Gerald Cox 2016-10-11 15:43:38 UTC
(In reply to Stanislav Graf from comment #21)
> (In reply to Gerald Cox from comment #20)
> 
> My experience matches that too, I have paid account. Thanks for noticing
> this difference.

Yeah, typical Google... seems like if you actually pay for anything with them you typically get a worse overall experience... i.e.  Google Apps accounts.

Comment 24 Gerald Cox 2016-10-19 12:40:04 UTC
The Chromium ticket was updated and they reported that they were unable to reproduce the issue with a "test account".  Not sure what that means, nor how they tested.  I requested they explain how they tested to ensure they understand the conditions where the bug occurs:

===
Another person using the Fedora Chromium reported the exact same symptoms as I am experiencing.  Seems weird that two people have been able to reproduce this but you can't.  

Did you:

1.  Read the Fedora bug report
2.  Test with Fedora Chromium... if you didn't test with Fedora Chromium, what Chromium did you test with?  What distribution?  What version level?
3.  Remember, I'm having absolutely no issues with Google Chrome... that works perfect... only having issues trying to use a paid Google Music Account with Fedora Chromium.  The free account works fine with Fedora Chromium.
===

It would be a good idea if anyone else is experiencing this issue to report it on the Chromium ticket:  
https://bugs.chromium.org/p/chromium/issues/detail?id=654774
which is now marked as "WONTFIX"


They suggested I contact Google Play Music support, but I suspect that is a fools errand because:

1.  Google doesn't support Fedora Chromium, they support Google Chrome
2.  Google Play paid accounts work perfectly fine with Google Chrome

Comment 25 Stanislav Graf 2016-10-19 15:00:46 UTC
Wouldn't better way forward be ticketing rpmfusion-free to provide chromium-libs-media replacement for package from Fedora?

I'm not convinced this is solvable in plain Fedora or plain Chromium without changes in Google Play Music part. And as you noted, supported browser Chrome works which makes it fools errand.

Comment 26 Rex Dieter 2016-10-19 15:10:45 UTC
I concur, since this cannot possibly work without at least pepperflash and/or nonfree chrome media codecs.

Comment 27 Gerald Cox 2016-10-19 15:14:19 UTC
(In reply to Rex Dieter from comment #26)
> I concur, since this cannot possibly work without at least pepperflash
> and/or nonfree chrome media codecs.

Rex, you're missing the point.  With the non-free stuff added it still doesn't work with a Google Play Music PAID account.  The FREE account works just fine.  In addition, this same exact issue was happening with the Vivaldi Browser as explained earlier in the ticket.  It has since been resolved.

Comment 28 Rex Dieter 2016-10-19 15:16:10 UTC
I'm not aware of any properly packaged nonfree media codec support for fedora's chromium... yet.

There are incomplete attempts and hacks yes, but until that's resolved, I don't think we can conclude anything one way or the other.

Comment 29 Gerald Cox 2016-10-19 15:28:15 UTC
(In reply to Rex Dieter from comment #28)
> I'm not aware of any properly packaged nonfree media codec support for
> fedora's chromium... yet.
> 
> There are incomplete attempts and hacks yes, but until that's resolved, I
> don't think we can conclude anything one way or the other.

All I can tell you is it worked using Chrome's Pepperflash with Tom's earlier builds.  It works fine with QupZilla using Chrome's Pepperflash.  QupZilla is based on an earlier Chromium build.  Vivaldi, when it first came out worked fine, then stopped, then started working again.  So yes, I don't think we can conclude anything with 100% certainty, but if it looks like a duck and walks like a duck, it most likely is a duck.

Comment 30 Tom "spot" Callaway 2017-03-08 19:25:28 UTC
It would be helpful to get people to retest things against chromium-56.0.2924.87. Things seem to be working much better on my end.

Comment 31 Stanislav Graf 2017-03-26 14:20:54 UTC
Still the same (tested with a paid account).
chromium-56.0.2924.87-3.fc25.x86_64
Plugins:
Widevine Content Decryption Module - Version: Something fresh
Adobe Flash Player - Version: 25.0.0.127

Comment 32 Fedora End Of Life 2017-07-25 22:07:33 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 33 Fedora End Of Life 2017-08-08 16:01:42 UTC
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.