Bug 1361501 - [virtio-win][balloon] report "VCRUNTIME120.dll is missing from your computer"error when using blnsvr.exe
Summary: [virtio-win][balloon] report "VCRUNTIME120.dll is missing from your computer"...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Gal Hammer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-29 08:11 UTC by Yu Wang
Modified: 2016-11-04 08:55 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:55:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Yu Wang 2016-07-29 08:11:01 UTC
Description of problem:
 report" The program cannot start because VCRUNTIME120.dll is missing from your computer"error when using blnsvr.exe

Version-Release number of selected component (if applicable):
virtio-win-prewhql-123

How reproducible:
100%

Steps to Reproduce:
1. boot guest with balloon device
   /usr/libexec/qemu-kvm -name 123BLNWIN832YTF -enable-kvm -m 3G -smp 4 -uuid edf5a2ae-a676-4f38-9247-a50b3f1a3034 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/123BLNWIN832YTF,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=123BLNWIN832YTF,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_enterprise_x86_dvd_917587.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=123BLNWIN832YTF.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:52:49:2f:aa:46,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7,disable-legacy=off,disable-modern=off
2.
3.

Actual results:
report error,cannot start blnsvr

Expected results:
start blnsvr successfully

Additional info:
1 win10-32 win8-32 win2016 all hit this issue
2 build 105 is ok, so it is a regression

Comment 3 Gal Hammer 2016-08-01 08:51:39 UTC
Fixed project's settings and posted a patch.

Comment 4 Peixiu Hou 2016-08-04 09:05:49 UTC
Verified this bug with virtio-win-prewhql-125 on Win200832, start blnsvr service successfully~~

Best Regards~
Peixiu Hou

Comment 5 lijin 2016-08-05 01:17:54 UTC
change status to verified according to comment#4

Comment 7 errata-xmlrpc 2016-11-04 08:55:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.