Bug 136154 - [PATCH] --log and --logfile in %post of kickstart crash anaconda
Summary: [PATCH] --log and --logfile in %post of kickstart crash anaconda
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-18 12:17 UTC by Gijs Hollestelle
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 16:35:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that adds --logfile and --log to argList so that they will be parsed by anaconda (512 bytes, patch)
2004-10-18 12:19 UTC, Gijs Hollestelle
no flags Details | Diff

Description Gijs Hollestelle 2004-10-18 12:17:48 UTC
Description of problem:
When I the new --log(file) option to %post in kickstart anaconda exits
with a backtrace stating that:

File "/usr/lib/anaconda/isys.py" Line 482, in getopt:
  return apply(_isys.getopt,args)
TypeError: bad argument --logfile unknown


Version-Release number of selected component (if applicable):
anaconda-10.0.3.17-1

How reproducible:
Always

Steps to Reproduce:
Create a kickstart file that has 
%post --logfile /var/log/kickstart.log

Additional info:

Seems to be a very easy fix, justt append logfile= and log= to the
argList value in kickstart.py on line 763, attaching a patch.

Comment 1 Gijs Hollestelle 2004-10-18 12:19:11 UTC
Created attachment 105373 [details]
Patch that adds --logfile and --log to argList so that they will be parsed by anaconda

Comment 2 Jeremy Katz 2004-10-18 13:18:49 UTC
Thanks for the patch, fixed in CVS

Comment 3 Gijs Hollestelle 2005-07-05 20:03:45 UTC
Is there any reason this bug is still open 10 months after it has been fixed? 

(Sorry if I should have done something to close this)

Comment 4 Rahul Sundaram 2005-08-15 16:35:34 UTC
Just hasnt been marked closed. Doing that now. 


Note You need to log in before you can comment on or make changes to this bug.