Bug 1361616 - SELinux is preventing fprintd from 'wake_alarm' accesses on the capability2 Unknown.
Summary: SELinux is preventing fprintd from 'wake_alarm' accesses on the capability2 U...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 25
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f61a6e778063647f6d62ad36f8f...
: 1366852 (view as bug list)
Depends On:
Blocks: F25FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-07-29 14:16 UTC by Joachim Frieben
Modified: 2016-09-05 11:22 UTC (History)
16 users (show)

Fixed In Version: selinux-policy-3.13.1-208.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-17 03:05:28 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2016-07-29 14:16:06 UTC
Description of problem:
SELinux is preventing fprintd from 'wake_alarm' accesses on the capability2 Unknown.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that fprintd should be allowed wake_alarm access on the Unknown capability2 by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'fprintd' --raw | audit2allow -M my-fprintd
# semodule -X 300 -i my-fprintd.pp

Additional Information:
Source Context                system_u:system_r:fprintd_t:s0
Target Context                system_u:system_r:fprintd_t:s0
Target Objects                Unknown [ capability2 ]
Source                        fprintd
Source Path                   fprintd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-204.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.8.0-0.rc0.git2.1.fc25.x86_64 #1
                              SMP Thu Jul 28 19:11:53 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-07-29 16:10:22 CEST
Last Seen                     2016-07-29 16:10:22 CEST
Local ID                      93e84f93-d16a-4642-82cb-dbb12be55405

Raw Audit Messages
type=AVC msg=audit(1469801422.831:258): avc:  denied  { wake_alarm } for  pid=2077 comm="fprintd" capability=35  scontext=system_u:system_r:fprintd_t:s0 tcontext=system_u:system_r:fprintd_t:s0 tclass=capability2 permissive=1


Hash: fprintd,fprintd_t,fprintd_t,capability2,wake_alarm

Version-Release number of selected component:
selinux-policy-3.13.1-204.fc25.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.0-0.rc0.git2.1.fc25.x86_64
type:           libreport

Comment 1 Jared Smith 2016-08-03 08:40:44 UTC
Description of problem:
Fingerprint scanner is causing SELinux alerts

Version-Release number of selected component:
selinux-policy-3.13.1-205.fc26.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.0-0.rc0.git3.1.fc26.x86_64
type:           libreport

Comment 2 Zdenek Chmelar 2016-08-07 20:07:40 UTC
Description of problem:
Error popped up after login to desktop

Version-Release number of selected component:
selinux-policy-3.13.1-206.fc26.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.0-0.rc0.git5.1.fc26.x86_64
type:           libreport

Comment 3 Chris Murphy 2016-08-10 17:25:29 UTC
This is also happening on Fedora 24 since selinux-policy-3.13.1-191.8.fc24.noarch, it happens most anytime I use sudo and type in a password.

time->Wed Aug 10 11:16:23 2016
type=AVC msg=audit(1470849383.290:336): avc:  denied  { wake_alarm } for  pid=3154 comm="fprintd" capability=35  scontext=system_u:system_r:fprintd_t:s0 tcontext=system_u:system_r:fprintd_t:s0 tclass=capability2 permissive=0

Comment 4 Medic Momcilo 2016-08-11 07:34:36 UTC
Description of problem:
Started dnf --refresh upgrade and this popped up.

Version-Release number of selected component:
selinux-policy-3.13.1-207.fc26.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.0-0.rc1.git0.1.fc26.x86_64
type:           libreport

Comment 5 Lukas Vrabec 2016-08-11 11:14:55 UTC
Rado,
 
Any ideas here?

Comment 6 Daniel Walsh 2016-08-11 14:15:28 UTC
We should dontaudit this and then get fprintd to fix the issue. But I am not sure what is causing it.

Comment 7 Lukas Vrabec 2016-08-11 22:35:59 UTC
Dan, 
After discussion with Radovan, maybe fprintd block suspending during authentication. Maybe we should allow it.

Comment 8 Fedora Update System 2016-08-12 15:58:26 UTC
selinux-policy-3.13.1-208.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-662487f8f1

Comment 9 Kamil Páral 2016-08-16 06:24:59 UTC
Description of problem:
This popped up on me on first boot after a default Workstation Live install (Fedora-Workstation-Live-x86_64-25-20160815.n.2.iso). I just started terminal and ran dnf, nothing else. Not sure whether this occurred before or after.

Version-Release number of selected component:
selinux-policy-3.13.1-207.fc25.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.0-0.rc1.git0.1.fc25.x86_64
type:           libreport

Comment 10 Kamil Páral 2016-08-16 06:25:46 UTC
Proposing as a Final blocker:
"There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop. "
https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria#SELinux_and_crash_notifications

Comment 11 Lukas Vrabec 2016-08-16 16:06:29 UTC
*** Bug 1366852 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2016-08-17 03:03:36 UTC
selinux-policy-3.13.1-208.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Giulio 'juliuxpigface' 2016-08-17 18:19:22 UTC
Description of problem:
I've encountered this while using Gnome, some minutes after the login. I don't think I did a specific action.

Version-Release number of selected component:
selinux-policy-3.13.1-207.fc25.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.0-0.rc0.git3.1.fc25.x86_64
type:           libreport


Note You need to log in before you can comment on or make changes to this bug.