Bug 136162 - PS2 trackpad on laptop does not work
PS2 trackpad on laptop does not work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 10:09 EDT by S Austin
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 02:02:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description S Austin 2004-10-18 10:09:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
SV1; .NET CLR 1.1.4322)

Description of problem:
kernel fails to recognize internal (PS/2) trackpad (touchpad) but 
will recognize USB mouse.  Device was not recognized when booting the 
install CD and has not been recognized by any version of the kernel 
I've built from source.  Tried turning on legacy ps/2 (/dev/psaux) 
and PCI PS2 (pcips2) devices in kernel but still no input from 
touchpad.

Possibly related to bug # 123851 ... on my laptop, there is no 
external PS/2 port.  If 123851 is related, then the kernel could 
detect the internal keyboard first, then fail to detect the touchpad.


Version-Release number of selected component (if applicable):
kernel-2.6.8-1.521

How reproducible:
Always

Steps to Reproduce:
1. Boot from 2.6.5 or 2.6.8 kernel on laptop equipped with internal 
PS/2 touchpad
2. Let startup script run gpm, or start X window system, or 
cat /dev/input/mice

Actual Results:  No response when attempting to use touchpad to move 
cursor

Expected Results:  gpm, X - expected cursor to move when touching 
touchpad
cat - expected data to be output to console when touching touchpad

Additional info:

Plug in a USB mouse and all three tests work as expected when using 
the mouse - still no response from the trackpad though.
Comment 1 S Austin 2004-10-20 16:02:59 EDT
Workaround:

get latest kernel source (I'm using 2.6.8-1.521) so you can build 
PS/2 mouse support as a module.

either edit .config file and set CONFIG_MOUSE_PS2=m or
use make menuconfig and set PS/2 mouse (under Device Drivers/input 
devices) to "m"

make clean (follow instructions in README file in src directory)
make modules_install

copy the resulting boot image to where you boot from (/boot for 
example) and add it to the appropriate boot config file (e.g. 
boot.conf)

mkinitrd to build the matching .img file
copy the System.map file there too

reboot and select the new kernel

gpm will probably be started in your startup script 

login as root (assuming you boot to init 3 console login prompt)

gpm -k (to kill gpm)
modprobe psmouse
gpm -m /dev/input/mice -t ps2

you should see the cursor appear and now be able to use the trackpad 
in both console and X.

I'm still fiddling with the xorg.conf file and synaptics driver.

Comment 2 Dave Jones 2005-04-16 02:02:26 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.