Bug 1361694 - ls output changed to include quoting space characters in coreutils 8.25
Summary: ls output changed to include quoting space characters in coreutils 8.25
Status: CLOSED DUPLICATE of bug 1349701
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils
Version: 24
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-29 18:56 UTC by Graham White
Modified: 2017-04-20 08:57 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-07-29 20:54:22 UTC


Attachments (Terms of Use)

Description Graham White 2016-07-29 18:56:39 UTC
Description of problem:
For some reason the coreutils developers have changed the output of the ls command such that ls will now output single quote characters around file names containing spaces.  This is a change to the default behaviour of a command that has had consistent output for 30-40 years.  I would like Fedora to consider adding the -N option to /etc/profile.d/colorls.sh in order to return the output of the ls command to the traditional default on Fedora systems.

This appears to have caused a lot of annoyance elsewhere
e.g. http://unix.stackexchange.com/questions/258679/why-is-ls-suddenly-wrapping-items-with-spaces-in-single-quotes
e.g. http://lists.gnu.org/archive/html/coreutils/2016-02/msg00000.html

Version-Release number of selected component (if applicable):
Coreutils 8.25

How reproducible:
Run the ls command in a directory containing a file with a space in the name.  Observe the quoted file name.

Note, other distributions are disabling this by reverting the patch.  Debian, for example (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=813164#msg210) and therefore Ubuntu and the other variants.  OpenSuSE already use the -N option to ls by default so that distro will not be effected.

Comment 1 Kamil Dudka 2016-07-29 20:54:22 UTC
You are welcome to discuss this with GNU coreutils upstream.  I fail to see how Fedora is special regarding handling files with spaces in their names.  Instead of asking individual downstream maintainers to revert, it would be more useful to explain upstream why you think it is a bad idea.  Apparently not all distros revert.  For example, Gentoo Linux adheres to upstream and I have never had any problems with that.

*** This bug has been marked as a duplicate of bug 1349701 ***

Comment 2 Pádraig Brady 2016-07-30 11:02:19 UTC
Note when discussing this, please detail _why_ you want the change.

The summarized reason for the change was the output is now always usable.
I.E. you can always copy/paste the output, and that usage will be _safe_.

Aesthetically it's a slight regression. Very slight in my opinion,
but we have some ideas to improve that in the next version.
For those who care, it's not too onerous to add -N to your ls alias

Comment 3 Graham White 2016-08-01 07:29:43 UTC
(In reply to Pádraig Brady from comment #2)
> Note when discussing this, please detail _why_ you want the change.
> 
> The summarized reason for the change was the output is now always usable.
> I.E. you can always copy/paste the output, and that usage will be _safe_.
> 
> Aesthetically it's a slight regression. Very slight in my opinion,
> but we have some ideas to improve that in the next version.
> For those who care, it's not too onerous to add -N to your ls alias

I understand you want to know _why_ but since I've seen lots of other people being ignored who have given good reason I see little point in constructing another argument that will also get ignored.  I'll live with -N in my alias instead.

Comment 4 Harald Reindl 2017-04-20 08:57:52 UTC
this idiotic behavior change results in bugreports like https://bugs.php.net/bug.php?id=74472 where fools don't realize that the quotes where never part of the filename and accuse other software that it has removed them


Note You need to log in before you can comment on or make changes to this bug.