Bug 1361793 - Dashboard gives undefined method `name' for nil:NilClass
Summary: Dashboard gives undefined method `name' for nil:NilClass
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1360771 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-30 14:32 UTC by David Davis
Modified: 2019-11-14 08:50 UTC (History)
20 users (show)

Fixed In Version: rubygem-katello-3.0.0.73-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-22 06:36:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
RHEL6 6.2.0 Hotfix RPM (5.41 MB, application/octet-stream)
2016-08-15 20:16 UTC, Mike McCune
no flags Details
RHEL7 6.2.0 Hotfix RPM (4.82 MB, application/octet-stream)
2016-08-15 20:18 UTC, Mike McCune
no flags Details
RHEL6 6.2.1 Hotfix RPM (5.41 MB, application/octet-stream)
2016-08-18 21:28 UTC, Mike McCune
no flags Details
RHEL7 6.2.1 Hotfix RPM (4.82 MB, application/octet-stream)
2016-08-18 21:29 UTC, Mike McCune
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1643 normal SHIPPED_LIVE Satellite 6.2 Upgrades Bugfixes 2016-08-22 10:35:37 UTC
Foreman Issue Tracker 13823 None None None 2016-08-15 17:00:05 UTC
Foreman Issue Tracker 14205 None None None 2016-08-14 00:06:20 UTC
Foreman Issue Tracker 16103 None None None 2016-08-13 23:46:51 UTC

Description David Davis 2016-07-30 14:32:46 UTC
Description of problem:

Customers are hitting this bug that fixed upstream:

http://projects.theforeman.org/issues/14205

Would like to get this into the next 6.2 build.

Comment 1 Bryan Kearney 2016-07-30 16:16:34 UTC
Upstream bug assigned to jsherril@redhat.com

Comment 2 Bryan Kearney 2016-07-30 16:16:36 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14205 has been closed

Comment 9 Mike McCune 2016-08-13 23:46:26 UTC
This fix does not properly address

Comment 11 Justin Sherrill 2016-08-15 13:02:30 UTC
I'm not certain that this is not properly addressed.  See https://bugzilla.redhat.com/show_bug.cgi?id=1365299 for a very very similar issue with a different traceback and different cause.

Mike, Do you have a full traceback from a satellite where this did not fix the problem?

Comment 12 Mike McCune 2016-08-15 20:14:12 UTC
** Satellite 6.2.0 HOTFIX RPMS **

We are attaching hotfix RPMs for Satellite version 6.2.0. These RPMs can only be used with a Satellite that has tfm-rubygem-katello-3.0.0.68 installed. Later versions should not be downgraded to include this fix.


Instructions for use:

* Download attached hotfix RPMs from this bugzilla
* install the correct RPM that matches with your version of Red Hat Enterprise Linux (el7 or el6 suffix in the RPM).
* restart httpd on your Satellite

After this the dashboard should render correctly.

If you still experiencing a NilClass error please see if the error matches that found within: https://bugzilla.redhat.com/show_bug.cgi?id=1365299 which is being fixed currently.

Comment 13 Mike McCune 2016-08-15 20:16:16 UTC
Created attachment 1190983 [details]
RHEL6 6.2.0 Hotfix RPM

Comment 14 Mike McCune 2016-08-15 20:18:37 UTC
Created attachment 1190984 [details]
RHEL7 6.2.0 Hotfix RPM

Comment 16 Mike McCune 2016-08-16 21:51:27 UTC
*** Bug 1360771 has been marked as a duplicate of this bug. ***

Comment 21 David Davis 2016-08-18 18:08:31 UTC
I think these steps should reproduce the bug:

1. Create an environment (e.g. Dev)
2. Create a content view and promote it to the environment
3. Remove the environment.
4. Visit the dashboard page and verify that it loads successfully.

Comment 23 Mike McCune 2016-08-18 21:24:07 UTC
** Satellite 6.2.1 HOTFIX RPMS **

Attaching 6.2.1 hotfix RPMS, same instructions apply as found in comment #12.

Comment 25 Mike McCune 2016-08-18 21:28:57 UTC
Created attachment 1191990 [details]
RHEL6 6.2.1 Hotfix RPM

Comment 26 Mike McCune 2016-08-18 21:29:55 UTC
Created attachment 1191991 [details]
RHEL7 6.2.1 Hotfix RPM

Comment 29 jcallaha 2016-08-19 19:43:44 UTC
Followed steps detailed in #21 and encountered no errors on the dashboard. The content view events referring to the now deleted environment were also removed.

Comment 32 Mike McCune 2016-08-22 02:14:36 UTC
There is an errata shipping on Monday Aug 22 to resolve this issue

Comment 33 Mike McCune 2016-08-22 02:22:52 UTC
Detailed HOTFIX instructions:

* If you have tfm-rubygem-katello-3.0.0.68 you want the Satellite 6.2.0 Hotfix RPM as linked in Comment #12:

tfm-rubygem-katello-3.0.0.68-2.hotfix.1361793.git.1.1a306a5

* If you have tfm-rubygem-katello-3.0.0.70 or later, you want the Satellite 6.2.1 Hotfix RPM as listed in comment #23: 

tfm-rubygem-katello-3.0.0.73-1

alternatively when RHBA-2016:24541-04 is released you can yum update a follow the standard upgrade procedure.

Comment 34 errata-xmlrpc 2016-08-22 06:36:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1643


Note You need to log in before you can comment on or make changes to this bug.