Bug 13618 - libstdc++-2.96-54.i386.rpm is v2, not v3
Summary: libstdc++-2.96-54.i386.rpm is v2, not v3
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libstdc++ (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-09 06:24 UTC by james muncy
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 00:15:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description james muncy 2000-07-09 06:24:01 UTC
Name        : libstdc++                    Relocations: (not relocateable)
Version     : 2.96                              Vendor: Red Hat, Inc.
Release     : 33                            Build Date: Mon Jul  3 11:54:25
2000
Install date: (not installed)               Build Host:
porky.devel.redhat.com
Group       : System Environment/Libraries   Source RPM:
gcc-2.96-33.src.rpm
Size        : 418016                           License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://gcc.gnu.org
Summary     : GNU c++ library
Description :
The libstdc++ package contains a snapshot of the GCC Standard C++
Library v3, an ongoing project to implement the ISO 14882 Standard C++
library.

-----------------------------------
The header of libstdc++-2.96-33.i386.rpm clains to provide v3.
This is __not__ so. Even though /libstdc++-v3/ is included in
the src.rpm , /libstdc++/ is being used to build the library thus
giving only v2

Comment 1 james muncy 2000-07-27 04:05:03 UTC
libstdc++-2.96-41.i386.rpm and libstdc++-devel-2.96-41.i386.rpm are still
built with Version 2, _not_ libstdc++-v3.

Comment 2 james muncy 2000-10-03 14:49:27 UTC
Redhat 7.0 is out and this has not been fixed.

Comment 3 dg 2000-10-30 12:56:04 UTC
Agreed - a great pity, since one of the main reasons I would have gone for using
2.96-x is for the v3 stdc++ lib; an absolute must for compliance or working with
C++ from anywhere else.
(And the v3 stdc++ lib has been stable for quite a while; well more so than the
v2 stuff....)

(You can see this is the case by dififng the installed headers with the ones in
libstdc++/ rather than libstdc++-v3 from the build tree).

Comment 4 Jakub Jelinek 2000-10-30 13:07:43 UTC
It is bug just in the %description lines of the spec file but could not be
changed because spec file translations were frozen at that time for RHL 7.0.
libstdc++-v3 is nowhere near stable library, there are quite a few bugs still
lurking in it (both in it and in g++ -fnew-abi which should go with it).


Note You need to log in before you can comment on or make changes to this bug.