Bug 136184 - There are missing dependencies
There are missing dependencies
Status: CLOSED DUPLICATE of bug 134671
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
unspecified
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Max Spevack
:
Depends On:
Blocks: 123188
  Show dependency treegraph
 
Reported: 2004-10-18 12:25 EDT by Need Real Name
Modified: 2007-08-06 11:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-10-18 12:25:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040928
Firefox/0.10

Description of problem:
The following rpms are required for installation of satellite.  They
are not documented and the installer crashes if they are not installed
before running install.sh

  rpm-build
  gd
  newt-perl


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Don't install undocumented prereqs
2.Run install.sh
    

Actual Results:  Traceback and command prompt.

Expected Results:  Prereqs should have been installed?

Additional info:
Comment 1 Robin Norwood 2004-10-18 12:32:54 EDT
Misa,

I think these are all fixed in 3.6 - can you confirm?

Also, why are we requiring newt-perl??
Comment 2 Mihai Ibanescu 2004-10-18 14:15:05 EDT
Not sure what requires newt-perl.
Comment 3 Robin Norwood 2004-10-18 23:44:34 EDT
# rpm -q --whatrequires newt-perl
crypto-utils-2.0-4
# rpm -q --whatrequires crypto-utils
no package requires crypto-utils

This is with a 3.6 sat built -11 - either something changed, or the
submitter is mistaken.

Test plan:

Install an RHN3.6.0 sat, with an @ Base package set.  The package
install section (part of the install.sh script) should run with no errors.
Comment 4 Todd Warner 2004-10-21 12:52:02 EDT
QA push. {ON_DEV,QA_READY} --> ON_QA
Comment 5 Max Spevack 2004-10-23 22:28:42 EDT

*** This bug has been marked as a duplicate of 134671 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:06:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.