Bug 136199 - rhgb-0.11.2-8 complains bad umount
rhgb-0.11.2-8 complains bad umount
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhgb (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 14:01 EDT by H.J. Lu
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 10:01:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description H.J. Lu 2004-10-18 14:01:11 EDT
I got

umount: invalid argument
umount: umount /initrd failed

during the boot on x86_64 with kernel 2.6.8-1.624. Machine seems to
work fine otherwise.
Comment 1 Bill Nottingham 2004-10-18 14:54:21 EDT
This code hasn't changed at all recently. Is something mounted on
/initrd after you boot? Did you boot with an initrd?
Comment 2 H.J. Lu 2004-10-18 15:14:21 EDT
Old initrd:

fil[hjl@gnu-20 tmp]$ file foo
foo: Linux rev 1.0 ext2 filesystem data

New initrd:

[hjl@gnu-64 tmp]$ file foo
foo: ASCII cpio archive (SVR4 with no CRC)

I am not sure if the new /initrd is mounted at all during the boot.
It doesn't look like it is. If it is true, umount /initrd will lead
to those messages.
Comment 3 Bill Nottingham 2004-10-18 15:29:06 EDT
No, it should be mounted.
Comment 5 Bill Nottingham 2004-10-18 17:41:41 EDT
Hm, the umount is wrapped in a check that it's actually mounted. So
presumably there is something mounted there.
Comment 6 H.J. Lu 2004-10-18 18:02:34 EDT
It may come from mkinitrd-4.1.18-1. It puts

umount /initrd/dev

in init in initrd.
Comment 7 H.J. Lu 2004-11-17 13:34:57 EST
The problem is rhgb-0.11.2-8 in RHEL 4 B2:

[root@gnu-5 log]# rpm -q rhgb
rhgb-0.11.2-8
[root@gnu-5 log]# /usr/bin/rhgb
umount2: Invalid argument
umount: /initrd: not mounted

/usr/bin/rhgb is used by /etc/rc.d/rc.sysinit.
Comment 9 Daniel Veillard 2004-11-30 10:01:21 EST
An update rhgb-0.14.1-5 fixing the bug has been pushed to RHEL-4.
It should fix this problem,

  thanks,

Daniel

Note You need to log in before you can comment on or make changes to this bug.