Bug 1362012 - ipa hbactest produces error about cannot concatenate 'str' and 'bool' objects
Summary: ipa hbactest produces error about cannot concatenate 'str' and 'bool' objects
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
: 1364293 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-01 07:52 UTC by Jan Pazdziora
Modified: 2016-11-04 05:59 UTC (History)
5 users (show)

Fixed In Version: ipa-4.4.0-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:59:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Jan Pazdziora 2016-08-01 07:52:31 UTC
Description of problem:

Running ipa hbactest now fails with

ipa: ERROR: TypeError: cannot concatenate 'str' and 'bool' objects
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1350, in run
    sys.exit(api.Backend.cli.run(argv))
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1115, in run
    rv = cmd.output_for_cli(self.api.Backend.textui, result, *args, **options)
  File "/usr/lib/python2.7/site-packages/ipaclient/plugins/hbactest.py", line 52, in output_for_cli
    textui.print_indented(result)
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 251, in print_indented
    print((CLI_TAB * indent + text))
TypeError: cannot concatenate 'str' and 'bool' objects
ipa: ERROR: an internal error has occurred

Version-Release number of selected component (if applicable):

ipa-admintools-4.4.0-4.el7.noarch
python2-ipalib-4.4.0-4.el7.noarch
python2-ipaclient-4.4.0-4.el7.noarch

It's the same version IdM on the server side.

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have IPA enrolled client, some user and HBAC service.
2. Run ipa hbactest --user=bob --host=wiki.example.test --service=wikiapp

Actual results:

--------------------
Access granted: True
--------------------
  Matched rules: allow_wikiapp
  Not matched rules: allow_all_users_services
ipa: ERROR: TypeError: cannot concatenate 'str' and 'bool' objects
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1350, in run
    sys.exit(api.Backend.cli.run(argv))
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1115, in run
    rv = cmd.output_for_cli(self.api.Backend.textui, result, *args, **options)
  File "/usr/lib/python2.7/site-packages/ipaclient/plugins/hbactest.py", line 52, in output_for_cli
    textui.print_indented(result)
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 251, in print_indented
    print((CLI_TAB * indent + text))
TypeError: cannot concatenate 'str' and 'bool' objects
ipa: ERROR: an internal error has occurred

Expected results:

No traceback, no error.

Additional info:

Comment 4 Petr Vobornik 2016-08-02 10:55:09 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6157

Comment 5 Martin Bašti 2016-08-04 15:14:14 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/cad6a551d6558441ead4b2b71d0b906ecefbdb63

Comment 6 Martin Bašti 2016-08-05 08:08:53 UTC
*** Bug 1364293 has been marked as a duplicate of this bug. ***

Comment 8 Scott Poore 2016-08-05 15:57:47 UTC
Verified.

Version ::

ipa-server-4.4.0-5.el7.x86_64

Due to 389 bug, had to downgrade back to 389-ds-base-1.3.5.10-5.el7 to verify this.

Results ::

[root@rhel7-5 yum.local.d]# ipa hbactest --user=bob --host=wiki.example.test --service=wikiapp
--------------------
Access granted: True
--------------------
  Matched rules: allow_all

No longer seeing the traceback failure.

Comment 10 errata-xmlrpc 2016-11-04 05:59:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.