Bug 136214 - Segfault from fstab-sync
Segfault from fstab-sync
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-18 15:07 EDT by Michal Jaegermann
Modified: 2013-03-05 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 21:36:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-10-18 15:07:16 EDT
Description of problem:


Version-Release number of selected component (if applicable):
hal-0.4.0-3

How reproducible:
100%
Comment 1 Michal Jaegermann 2004-10-18 15:09:04 EDT
Oops!  Hit a wrong key.  This was supposed to be in a "Description":

# fstab-sync 
Usage:Segmentation fault

That seems to be a tad to self-critical. :-)
Comment 2 Michal Jaegermann 2004-10-18 15:13:19 EDT
Maybe this gives a bit better picture

# fstab-sync -v
5222: mount_root='/media'
5222: use_managed=1
5222: managed primary='managed'
5222: managed secondary='kudzu'
Usage: [OPTION...]
Segmentation fault

This is on x86_64, BTW.
Comment 3 David Zeuthen 2004-10-18 15:19:41 EDT
I can confirm this; it btw works when called out from hal or when
given the -h option so this should be another easy fix. Thanks.
Comment 4 David Zeuthen 2004-10-18 21:36:36 EDT
This should be fixed in hal-0.4.0-4. Thanks.

Note You need to log in before you can comment on or make changes to this bug.