Bug 136222 - GRUB doesn't on SCSI
GRUB doesn't on SCSI
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 15:20 EDT by Maarten
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 10:55:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maarten 2004-10-18 15:20:40 EDT
Description of problem:
GRUB doesn't load thru MBR or Sector using SCSI

Version-Release number of selected component (if applicable):
0.95 or something

How reproducible:
Always

Steps to Reproduce:
BIOS hd boot setup: HDA1, SDA1, HDA2
1. 3 HD's: 1 HD on SCSI and 2 HD's on IDE
2. Set IDE HD as master boot device and install Windows 2000 on HDA1 NTFS
3. Install FC on SCSI (second boot device) and place GRUB in first sector
4. Tried to get to LINUX root to make a copy of GRUB bootsector but FC
CD doesn't allow me to
5. Tried thru boot floppy succesfully but the Windows boot.ini doesn't
start the linux boot binary

Other way (step 1 and 2 are the same):
BIOS hd boot setup: SDA1, HDA1, HDA2
3. Set SCSI as primary boot device
4. Install FC and the GRUB to MBR of the SDA
5. Reboot system

Actual results:
GRUB fails to load and doesn't show error messages

Expected results:
Proper loading of linux

Additional info:
There's only 1 SCSI drive which is a Compaq MAN3184MP connected to a
Adaptec AIC-7892 SCSI PCI card.
It's a Intel D845PESV system board with a Intel P4 2.53G with Samsung
512MB DDR333
3 PCI soundcards (Terratec EWX 24/96, DMX 6-fire LT, Marian MARC 4 DIGI)
nVidia GeForce 4 Ti 4800 SE
Comment 1 Jeremy Katz 2004-10-18 17:32:42 EDT
What order did you choose for the drives on the advanced boot loader
screen?  Unfortunately, PC BIOSes don't expose a way to map BIOS
drives to actual system drives in a way that is consistent or usable
and thus on systems with multiple controllers like this, you have to
manually give a hint as to what the "correct" for your BIOS settings is.
Comment 2 Maarten 2004-10-18 23:19:34 EDT
device.map:
(fd0)     /dev/fd0
(hd0)     /dev/hda
(hd1)     /dev/hdb
(hd2)     /dev/sda

grub.conf:
default=0
timeout=15
splashimage=(hd2,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.18-14)
    root (hd2,0)
    kernel /vmlinuz-2.4.18-14 ro root=LABEL=/ hdd=ide-scsi
    initrd /initrd-2.4.18-14.img
title DOS
    rootnoverify (hd0,0)
    chainloader +1

I tried by copying "stage1" to c: with no luck

I tried:
  dd if=/dev/sda1 of=/mnt/floppy/bootsda1.lin bs=512 count=1
but the file didn't have any content so i did:
  grub-install /dev/sda1
worked and now the "dd" command outputted a file with content to
floppy. Copied the floppy content to C: (hd0,0) because somehow it
didn't want to mount HDA1

All times the screen only outputs "GRUB" and the CD drives where not
loaded yet.
I even tried with turning off Int13 in SCSI card setup.

Structures:
hda1: NTFS
hda2: hda5 NTFS, hda6 FAT32
hdb1: NTFS 
sda1: ext3 /boot
sda2: swap
sda3: ext3 /
Comment 3 Maarten 2004-10-19 08:49:50 EDT
Working now thru 1 setup:
1. Install Windows 2000 on HDA1
2. Install Linux on SDA
3. Install GRUB on hda1 MBR and add additional parameter "hdd=ide-scsi"

All others failed
Comment 4 Peter Jones 2005-01-10 11:42:44 EST
Are you sure that hd2 is right for the drive?  That is, that BIOS is mapping it
as last, and not first?  

If you change the device map to be:

(fd0)     /dev/fd0
(hd0)     /dev/hda
(hd1)     /dev/hdb
(hd2)     /dev/sda

And then swap hd0 and hd2 in the grub.conf in the original (broken) config, does
it work?
Comment 5 Maarten 2005-01-10 15:59:19 EST
Yes the BIOS maps the IDE drives first
Then it loads my SCSI card and maps the drives

But when i try to load GRUB from the SCSI it can't find it.
It seems GRUB searches on hda for the bootsector.

When i use GRUB in the MBR and let it start/load from there it works.
So instead of using the Win2k MBR i now use GRUB in the MBR
Comment 6 Matthew Miller 2006-07-10 17:18:00 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 7 John Thacker 2006-10-30 10:55:40 EST
Closing per lack of response to previous request for information.  This bug was
originally filed against a much earlier version of Fedora Core, and significant
changes have taken place since the last version for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.