Bug 1362382 - Missed capability, of widevine with Netflix
Summary: Missed capability, of widevine with Netflix
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 05:52 UTC by David Vásquez
Modified: 2016-10-21 15:51 UTC (History)
2 users (show)

Fixed In Version: chromium-52.0.2743.116-9.fc24 chromium-52.0.2743.116-10.fc25 chromium-52.0.2743.116-10.fc23 chromium-53.0.2785.143-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-21 15:51:40 UTC
Type: Bug


Attachments (Terms of Use)

Description David Vásquez 2016-08-02 05:52:40 UTC
Description of problem: I usually use other rpm of Chromium (Russian Fedora) or UnitedRpms, with the capability if Anyone put libwidevinecdm.so and libwidevinecdmadapter.so in the correctly path, play happy Netflix. However this does not work in this version.


Version-Release number of selected component (if applicable):

52.0.2743.82-9


How reproducible:


Steps to Reproduce:
1. Open url Netflix with Chromium and the necessary in the next path %{_libdir}/chromium/libwidevinecdm.so; %{_libdir}/chromium/libwidevinecdmadapter.so)


Actual results:

Display a code error M7355-1204

Expected results:
Play correctly Netflix with Chromium, similar to version (https://github.com/RussianFedora/chromium/blob/stable/chromium.spec)...


Additional info: Maybe the .spec can help us.

Comment 1 Tom "spot" Callaway 2016-08-10 14:33:43 UTC
I'm not exactly sure what we need to do here. I don't think turning on widevine is enough for Netflix, it probably depends on codecs we can't include in Fedora. Chromium is tricky with how it whitelists codec support, if we build widevinecdm, it might not think it can do h264 (for example).

It might make more sense for a 3rd party repo to build and provide widevine with full codec support enabled in the Chromium tree.

Comment 2 David Vásquez 2016-08-10 15:58:59 UTC
Hi, We no need include codecs here; Third party chromium's exist, because in the time. It was not approved in official repositories, but now is a reality. Various third-party as COPR users was deleted your versions because now is official. I don't have a powerful machine for examine each part of this .spec and rebuild (12 hours is the death for me); but I think  it need a patch; if "pepper" works fine putting the necesary  (yes pepper works fine in the official chromium), then widevine can works in the same way. We don't need include incompatible closed dependencies  with Fedora. In the changelog Jul 21 2016 "- try to enable widevine compatibility (you still need to get the binary .so files from chrome)" 
https://pkgs.fedoraproject.org/cgit/rpms/chromium.git/tree/chromium.spec.
But third-party solved it. It is the .spec from unitedrpms (https://github.com/UnitedRPMs/chromium/blob/master/chromium.spec). I can help to test all changes;  from other third-party project ;).

Comment 3 David Vásquez 2016-08-10 16:10:35 UTC
I completely forgot, I think so the bug is related to https://bugs.chromium.org/p/chromium/issues/detail?id=473866

Comment 4 Tom "spot" Callaway 2016-08-10 20:13:44 UTC
I think we're talking past each other here. I've already included the patch to build widevine from source, but in my testing, the resulting .so files do not result in Netflix working. I suspect it is due to the missing media codecs, because that is the remaining key difference between the Fedora chromium package and the 3rd party ones (UnitedRPMS, RussianFedora, etc).

I'm going to do more local testing to try to figure it out.

Comment 5 David Vásquez 2016-08-12 08:11:18 UTC
Maybe the patch (https://pkgs.fedoraproject.org/cgit/rpms/chromium.git/tree/chromium-52.0.2743.82-widevinefix.patch) affected the support for widevine :/



Please test it:

### build with widevine support

# Patch from crbug (chromium bugtracker)
# fix the missing define (if not, fail build) (need upstream fix) (https://crbug.com/473866)
sed '14i#define WIDEVINE_CDM_VERSION_STRING "Something fresh"' -i "third_party/widevine/cdm/stub/widevine_cdm_version.h"

# Hard code extra version
FILE=chrome/common/channel_info_posix.cc
sed -i.orig -e 's/getenv("CHROME_VERSION_EXTRA")/"UnitedRPMs Project"/' $FILE
cmp $FILE $FILE.orig && exit 1

Comment 6 Tom "spot" Callaway 2016-08-12 20:26:51 UTC
Okay. More testing.

It looks like the libwidevinecdm.so file that Chromium generates is just an empty shim. When I replace it with the Chrome libwidevinecdm.so file, DRM streams (including Netflix) starts working.

This makes sense, because UnitedRPMS is offering a "chromium-widevinecdm-plugin" package, that includes copies of those files (presumably taken from Google Chrome).

I think the best course of action for Fedora will be to build (and thus, enable Chromium for) widevinecdm, but not to actually include libwidevine*.so* in the package. Then third party repos can offer "chromium-widevinecdm-plugin" and users can install that and get working Netflix/DRM streams.

****

Thoughts?

Comment 7 David Vásquez 2016-08-12 21:40:56 UTC
Is a great idea, as I said above, similar to pepper (https://ask.fedoraproject.org/en/question/10217/sticky-how-do-i-install-adobe-flash-on-fedora/). When the people put the necessary '.so' in the correct path the capability is effective. If it is a reality, third-party chromium isn't necessary anymore. :)

Comment 8 Fedora Update System 2016-08-17 17:34:31 UTC
chromium-52.0.2743.116-9.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-19c0d6b4b2

Comment 9 Fedora Update System 2016-08-17 17:35:01 UTC
chromium-52.0.2743.116-9.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3431daeaf0

Comment 10 Fedora Update System 2016-08-17 17:35:20 UTC
chromium-52.0.2743.116-9.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a35f3eeea

Comment 11 Fedora Update System 2016-08-17 17:35:42 UTC
chromium-52.0.2743.116-9.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-95d9b62ed3

Comment 12 Fedora Update System 2016-08-17 19:51:51 UTC
chromium-52.0.2743.116-9.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-95d9b62ed3

Comment 13 Fedora Update System 2016-08-18 01:50:03 UTC
chromium-52.0.2743.116-9.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a35f3eeea

Comment 14 Fedora Update System 2016-08-18 01:51:02 UTC
chromium-52.0.2743.116-9.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3431daeaf0

Comment 15 Fedora Update System 2016-08-18 04:18:21 UTC
chromium-52.0.2743.116-9.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-19c0d6b4b2

Comment 16 David Vásquez 2016-08-19 05:26:28 UTC
Updated but, Widevine capability still Missed, even if I copied libwidevinecdm.so and libwidevinecdmadapter.so from the Google Chrome package into /usr/lib64/chromium-plugins (and restart chromium) https://fedoraproject.org/wiki/Chromium .

If I put in %{_libdir}/chromium-browser/; is detected widevine, but isn't work. You can test widevine (if anybody here don't have Netflix account) with this site http://player.kaltura.com/modules/Widevine/tests/Widevine.qunit.html?runQunitTests=1

Comment 17 Fedora Update System 2016-08-25 13:54:24 UTC
chromium-52.0.2743.116-9.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-08-26 13:32:47 UTC
chromium-52.0.2743.116-10.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2a0c80295c

Comment 19 Fedora Update System 2016-08-26 13:33:22 UTC
chromium-52.0.2743.116-10.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3a8d9311f8

Comment 20 Fedora Update System 2016-08-27 12:53:08 UTC
chromium-52.0.2743.116-10.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2a0c80295c

Comment 21 Fedora Update System 2016-08-27 22:21:39 UTC
chromium-52.0.2743.116-10.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3a8d9311f8

Comment 22 Fedora Update System 2016-08-29 19:25:41 UTC
chromium-52.0.2743.116-11.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e82affa05e

Comment 23 Fedora Update System 2016-08-31 13:49:42 UTC
chromium-52.0.2743.116-11.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-e82affa05e

Comment 24 Fedora Update System 2016-08-31 16:28:32 UTC
chromium-52.0.2743.116-10.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2016-09-09 16:54:42 UTC
chromium-52.0.2743.116-10.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2016-09-09 19:07:47 UTC
chromium-53.0.2785.101-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-6d70ae9a57

Comment 27 Fedora Update System 2016-09-10 05:48:38 UTC
chromium-53.0.2785.101-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-6d70ae9a57

Comment 28 Fedora Update System 2016-09-14 19:28:23 UTC
chromium-53.0.2785.113-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-449d647265

Comment 29 Fedora Update System 2016-09-15 23:52:04 UTC
chromium-53.0.2785.113-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-449d647265

Comment 30 Fedora Update System 2016-09-28 16:19:40 UTC
chromium-53.0.2785.116-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-bf5b9b3332

Comment 31 Fedora Update System 2016-10-04 13:19:32 UTC
chromium-53.0.2785.143-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-387d58ef27

Comment 32 Fedora Update System 2016-10-21 15:51:40 UTC
chromium-53.0.2785.143-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.