Bug 136242 - ImportError: No module named yummain
Summary: ImportError: No module named yummain
Status: CLOSED DUPLICATE of bug 136172
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-18 20:28 UTC by Mace Moneta
Modified: 2014-01-21 22:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:06:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mace Moneta 2004-10-18 20:28:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041016
Firefox/0.10.1

Description of problem:
Following upgrade to yum-2.1.8-1, yum update fails:

# yum update
Traceback (most recent call last):
  File "/usr/bin/yum", line 6, in ?
    import yummain
ImportError: No module named yummain


Version-Release number of selected component (if applicable):
yum-2.1.8-1

How reproducible:
Always

Steps to Reproduce:
1.Upgrade yum
2.yum update
3.Boom
    

Actual Results:  Traceback (most recent call last):
  File "/usr/bin/yum", line 6, in ?
    import yummain
ImportError: No module named yummain


Expected Results:  An update or not, depending on availability of new
releases.

Additional info:

This is a clean install of FC3T3, with daily updates via yum.  Yum has
worked fine until today's update.

Comment 1 Seth Vidal 2004-10-18 20:34:59 UTC

*** This bug has been marked as a duplicate of 136172 ***

Comment 2 Mace Moneta 2004-10-18 20:35:17 UTC
The problem appears to be in /usr/bin/yum, which contains:

   sys.path.insert(0, '/home/skvidal/cvs/yum-HEAD')

instead of:

   sys.path.insert(0, '/usr/share/yum-cli')

Comment 3 Red Hat Bugzilla 2006-02-21 19:06:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.