Bug 1362510 - not possible to import cluster with colocated journals
Summary: not possible to import cluster with colocated journals
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: core
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Shubhendu Tripathi
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: 1332984 1346188 Console-2-GA 1355962
TreeView+ depends on / blocked
 
Reported: 2016-08-02 12:03 UTC by Martin Kudlej
Modified: 2016-08-23 19:58 UTC (History)
5 users (show)

Fixed In Version: rhscon-core-0.0.41-1.el7scon.x86_64
Doc Type: If docs needed, set a value
Doc Text:
The Red Hat Storage Console 2 is targeted at production use cases and follows best practices strictly. There are cases however, where colocation of journals and OSD's are acceptable when the tradeoff in performance is acceptable for reason related to storage density and efficient usage of available disks. This configuration is supported on import of clusters but is not supported in creation of new clusters. The primary supported use case for the storage console is cases where either disks and journals are not colocated or one or more solid state disks is available and journals are created on those high performance devices.
Clone Of:
Environment:
Last Closed: 2016-08-23 19:58:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
unfinished task (65.16 KB, image/png)
2016-08-02 12:03 UTC, Martin Kudlej
no flags Details


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 286172 None None None 2016-08-03 10:24:08 UTC
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Martin Kudlej 2016-08-02 12:03:34 UTC
Created attachment 1186769 [details]
unfinished task

Description of problem:
I've created cluster with colocated journals which is supported Ceph configuration and I was not able to import it into Console.

Version-Release number of selected component (if applicable):
Server:
ceph-ansible-1.0.5-31.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.39-1.el7scon.x86_64
rhscon-core-0.0.39-1.el7scon.x86_64
rhscon-core-selinux-0.0.39-1.el7scon.noarch
rhscon-ui-0.0.51-1.el7scon.noarch
Monitor with Calamari:
calamari-server-1.4.7-1.el7cp.x86_64
ceph-base-10.2.2-32.el7cp.x86_64
ceph-common-10.2.2-32.el7cp.x86_64
ceph-mon-10.2.2-32.el7cp.x86_64
ceph-release-1-1.el7.noarch
ceph-selinux-10.2.2-32.el7cp.x86_64
libcephfs1-10.2.2-32.el7cp.x86_64
python-cephfs-10.2.2-32.el7cp.x86_64
rhscon-agent-0.0.16-1.el7scon.noarch
rhscon-core-selinux-0.0.38-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. install Ceph cluster with colocated journals with Ceph-ansible
2. import cluster into Console

Actual results:
Import does not finish. It is not timeouted.

Expected results:
If import fails related task should time-out. Importing of cluster with colocated journals should pass.

Comment 3 Shubhendu Tripathi 2016-08-03 06:24:50 UTC
@Tejas, looks like you had tried this flow and USM was able to import a cluster having collocated journals on OSD.
Can you please provide your comments and step followed here?

Comment 5 Shubhendu Tripathi 2016-08-08 11:39:52 UTC
The actual issue was not only for collocated journals on OSD but rather even any import cluster was failing.
This happened due a regression which caused a nil pointer exception.

The same is fixed as part of the patch https://review.gerrithub.io/#/c/286172/ and now import cluster works fine as expected.

Moving the BZ to MODIFIED state.

Comment 7 Martin Kudlej 2016-08-09 08:01:35 UTC
Tested with
ceph-ansible-1.0.5-32.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.40-1.el7scon.x86_64
rhscon-core-0.0.41-1.el7scon.x86_64
rhscon-core-selinux-0.0.41-1.el7scon.noarch
rhscon-ui-0.0.52-1.el7scon.noarch
and it works.

Comment 9 errata-xmlrpc 2016-08-23 19:58:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.