Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1362612 - rhel-osp-director: Existing nodes get rebuilt during scale out after updating overcloud image post 9.0->9Async update
Summary: rhel-osp-director: Existing nodes get rebuilt during scale out after updat...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Brad P. Crochet
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On: 1354627
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 16:04 UTC by Alexander Chuzhoy
Modified: 2016-08-24 13:01 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-common-2.0.0-8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-24 13:01:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1762 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Advisory 2016-08-24 16:59:57 UTC

Description Alexander Chuzhoy 2016-08-02 16:04:06 UTC
rhel-osp-director:   	Existing nodes get rebuilt during scale out after updating overcloud image post 9.0->9Async update

Environment:
openstack-puppet-modules-8.1.5-1.el7ost.noarch
instack-undercloud-4.0.0-8.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-18.el7ost.noarch
openstack-tripleo-heat-templates-kilo-2.0.0-18.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-18.el7ost.noarch


Steps to reproduce:
1. Deploy 9.0 with:
 openstack overcloud deploy --templates --control-scale 3 --compute-scale 1 --neutron-network-type vxlan --neutron-tunnel-types vxlan --ntp-server clock.redhat.com --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml --ceph-storage-scale 1
2. populate the overcloud
3. Update to 9.0Async
4. Update the overcloud images
5. Attempt to scale +1 compute

Result:
the scale fails. Looking on nova list and ironic node-list output shows that the existing nodes get rebuilt:
[stack@instack ~]$ ironic node-list
+--------------------------------------+------+--------------------------------------+-------------+--------------------+-------------+
| UUID                                 | Name | Instance UUID                        | Power State | Provisioning State | Maintenance |
+--------------------------------------+------+--------------------------------------+-------------+--------------------+-------------+
| f1f22c15-eb54-484f-8ea0-0065bc9841f3 | None | 5168ea6e-d1e2-46c4-8123-23cfabb799f4 | power on    | deploy failed      | False       |
| dd0ae530-83ba-4c9e-988e-d6efb69f8760 | None | None                                 | power off   | available          | False       |
| 59494be8-2879-4030-ac54-67d15e0e7b82 | None | 914bffc6-5ae2-496b-a38f-197534dba6d0 | power on    | deploy failed      | False       |
| d3e8dc58-ec74-4278-b696-9aae19ce4ad1 | None | None                                 | power off   | available          | False       |
| a897d56c-1653-44ee-ac2a-eb488505a944 | None | 93171f0b-b876-4b85-9c24-7ca82fe091f2 | power on    | deploy failed      | False       |
| e7c7e121-27cb-4652-b58f-5964338fa2d9 | None | ed44f1af-c28f-40c9-9059-6721ce3a0324 | power on    | deploy failed      | False       |
| 0bfe3c2b-e788-4d8b-8de0-6820806e5ab1 | None | None                                 | power off   | available          | False       |
| 5c6d6466-72a7-42c9-b98a-f017eec6e4ed | None | 73e22fc5-5673-409a-97fc-eb91f03122b6 | power on    | deploy failed      | False       |
+--------------------------------------+------+--------------------------------------+-------------+--------------------+-------------+


[stack@instack ~]$ nova list
+--------------------------------------+-------------------------+--------+------------+-------------+---------------------+
| ID                                   | Name                    | Status | Task State | Power State | Networks            |
+--------------------------------------+-------------------------+--------+------------+-------------+---------------------+
| 73e22fc5-5673-409a-97fc-eb91f03122b6 | overcloud-cephstorage-0 | ERROR  | -          | Running     | ctlplane=192.0.2.7  |
| 5168ea6e-d1e2-46c4-8123-23cfabb799f4 | overcloud-compute-0     | ERROR  | -          | Running     | ctlplane=192.0.2.8  |
| 7efdfb05-432b-4ce9-acab-0029a86f6d07 | overcloud-compute-1     | ERROR  | -          | NOSTATE     |                     |
| 93171f0b-b876-4b85-9c24-7ca82fe091f2 | overcloud-controller-0  | ERROR  | -          | Running     | ctlplane=192.0.2.11 |
| ed44f1af-c28f-40c9-9059-6721ce3a0324 | overcloud-controller-1  | ERROR  | -          | Running     | ctlplane=192.0.2.9  |
| 914bffc6-5ae2-496b-a38f-197534dba6d0 | overcloud-controller-2  | ERROR  | -          | Running     | ctlplane=192.0.2.10 |
+--------------------------------------+-------------------------+--------+------------+-------------+---------------------+



The fix should be the same as for
https://bugzilla.redhat.com/show_bug.cgi?id=1354627

Filed this BZ for explicitly testing/verifying the issue.

Comment 5 Alexander Chuzhoy 2016-08-15 17:22:43 UTC
Verified:
Environment:
openstack-tripleo-common-2.0.0-8.el7ost.noarch

The reported issue doesn't reproduce:

Comment 7 errata-xmlrpc 2016-08-24 13:01:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1762.html


Note You need to log in before you can comment on or make changes to this bug.