Bug 136263 - Konqueror denies access to directories with invalid unicode name
Konqueror denies access to directories with invalid unicode name
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 19:34 EDT by Hesty
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 03:52:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
torrent (75.19 KB, application/octet-stream)
2004-10-30 12:44 EDT, Hesty
no flags Details

  None (edit)
Description Hesty 2004-10-18 19:34:39 EDT
Description of problem:
If a directory has invalid unicode name, Konqueror locks the
directory. When user tries to access the directory (double click),
konqueror complains that the directory seems to not exist.

Nautilus seems to handle this quite well. It slaps "(Invalid Unicode)"
text at the end of the garbled unicode name and allows user to access
and even change the directory name.

Version-Release number of selected component (if applicable):
KDE that comes with FC2 (3.2?)

How reproducible:
Always.

Steps to Reproduce:
1. Name a directory with some invalid unicode characters.
2. Try to access the directory using konqueror.
  
Actual results:
Konqueror complains that directory seems to not exist.

Expected results:
Konqueror behaves and accesses the directory

Additional info:
Problems seems to be in Mandrake too. After googling a bit, here are
some more info:
http://www.pclinuxonline.com/pollcomments.php?op=Reply&pid=2662&pollID=161&mode=&order=&thold=
Comment 1 Ngo Than 2004-10-19 06:43:51 EDT
i have tried to reproduce this problem with your above instructions in
FC2 and FC3test3.

 cp startkde-afs.patch "äüößfileä.patch"
 mkdir "äüößfileä"

konqueror can access/change/rename this file and directory without any
problem. sorry, it works for me. please reopen it again if you have
exactly instructions how to reproduce this problem. Thanks




Comment 2 Hesty 2004-10-30 12:44:22 EDT
Created attachment 105976 [details]
torrent

Try opening this torrent file. It will create an invalid unicode directory as I
mentioned above.
Comment 3 Ngo Than 2004-11-02 10:19:54 EST
strange, i have opened this file with konqueror, it does not create
any invalid unicode directory!

could you please give more details? thanks
Comment 4 Hesty 2004-11-16 03:52:55 EST
Hmm.. I found out that Azureus correctly create the unicode directory
(with valid Unicode), but shad0w's client (using wxPython gui) created
the invalid Unicode directory name. 

In any case, it's fixed with FC3. Konqueror is now able to access the
invalid unicode directory.

Note You need to log in before you can comment on or make changes to this bug.