This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 136295 - gaim 1.0.0-5 requires aspell later than FC2
gaim 1.0.0-5 requires aspell later than FC2
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Reed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-19 04:45 EDT by Göran Uddeborg
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 05:06:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2004-10-19 04:45:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; sv-SE; rv:1.7.2)
Gecko/20040809

Description of problem:
When upgrading gaim to the one from FC3T3, but keeping apsell from
FC2, gaim crashes whenever sending or receiving messages.  At least
over ICQ and MSN.

Version-Release number of selected component (if applicable):
gaim-1.0.0-5 and aspell-0.50.3-19.1

How reproducible:
Always

Steps to Reproduce:
1.Install aspell from FC2
2.Instal gaim from FC3T3
3.Start gaim and try to send a message
    

Actual Results:  The gaim window disappears.  If I start gaim in an
xterm and do this, I get this message:

Gaim has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own. ...

Expected Results:  The message should be sent/received.

Additional info:

Upgrading to aspell-0.50.5-2.fc3 from FC3T3 resolves the problem.  So
a reasonable solution would be to add

  Requires aspell >= 0.50.5

to the gaim package.
Comment 1 Warren Togami 2004-10-19 05:06:08 EDT
Why did you try to do this?  You generally must use packages built on
the same distribution or there may be unpredictable results.  I'm
sorry that this is not enforced by an explicit or implicit dep, but
adding this would be too much of a maintenance burden as we maintain
the same .spec across RHEL3, FC1, FC2, FC3 and RHEL4.

Sorry.
Comment 2 Göran Uddeborg 2004-10-19 05:22:22 EDT
> Why did you try to do this?

The system isn't a pure FC2 system.  I'm upgrading, but don't want to
break everything at once, so I take it piecemal.  Whenever I need to
upgrade something, I take it from the most recent release.  Often from
a test release, if available, unless it is a critical package, so I
can do some testing at the same time.

It is of course reasonable for the new package to require the upgrade
of other packages too to work properly.  But if it does, it should say
so in its requirements.

Not that I expect everything to be perfect; I'm aware it is not easy
to know all such details.  But when I find it doesn't work I've
considered it a bug and reported it.  Like here! :-)

> You generally must use packages built on the same distribution or
> there may be unpredictable results.

While I understand this would make it easier from a maintenance point
of view, it has not previously been a requirement.  At least not
stated anywhere obvious.  And I would find it unfortunate if it became
one.  I may want to use old packages because you have discontinued
them, for example, or third party packages which do not exactly match
any particlular release.  Or pull a package from rawhide, without
taking everything from there.

Besides, a lot of the power in RPM would be pointless if you anyway
required everything to come from the same release.

Note You need to log in before you can comment on or make changes to this bug.