Bug 136306 - unable to uninstall cleanly
Summary: unable to uninstall cleanly
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: im-sdk   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: IIIMF
TreeView+ depends on / blocked
 
Reported: 2004-10-19 09:50 UTC by Lawrence Lim
Modified: 2014-03-26 00:51 UTC (History)
2 users (show)

Fixed In Version: im-sdk-12.1-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 05:32:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lawrence Lim 2004-10-19 09:50:20 UTC
Description of problem:
After performing a clean installation of im-sdk and chinput LE,
immediately perform an uninstall, it is not able to remove everything
in the /usr/lib64/im dir.

[root@dhcp-198 iiim]# pwd
/usr/lib64/im/share/iiim
[root@dhcp-198 iiim]# ls -la
æ»ç¨é 16
drwxr-xr-x  2 root root 4096 10æ 19 19:37 .
drwxr-xr-x  3 root root 4096 10æ 19 19:37 ..


Version-Release number of selected component (if applicable):
- im-sdk-12.1-1.x86_64
- iiimf-le-chinput-0.3-11.x86_64

How reproducible:
Always

Steps to Reproduce:
1.rpm -Uvh iiimf* (install im-sdk and iiimf-le-chinput)
2.rpm -e `rpm -qa |grep iiimf`
3.
  
Actual results:
Empty dir left behind

Expected results:
Everything gets removed.

Additional info:
Installing the im-sdk and uninstall works perfectly, its only after
installing chinput, the dir does not get removed.

Comment 1 Akira TAGOH 2004-10-20 12:13:11 UTC
I still suspect this problem is in im-sdk packages, because
iiimf-le-chinput doesn't have any files under that directory.

Comment 2 Akira TAGOH 2004-10-20 12:25:59 UTC
I found some missing owner directory thing in im-sdk. and fixed it.
hopefully this problem will be fixed in the next build.

Comment 3 Jens Petersen 2004-10-29 01:13:36 UTC
(directories in question are under %imdir/share)

Comment 4 Akira TAGOH 2004-11-01 11:38:10 UTC
should be fixed in 12.1-4

Comment 5 Lawrence Lim 2004-11-03 05:32:40 UTC
Confirmed fixed. Tested with im-sdk-12.1-5.


Thanks.


Note You need to log in before you can comment on or make changes to this bug.