Bug 136315 - mountpoints not moved to /media on update
mountpoints not moved to /media on update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-release (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-19 06:12 EDT by Matthias Bachert
Modified: 2014-03-16 22:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-30 04:27:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Bachert 2004-10-19 06:12:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
if you update fedora-core-2 to fedora-core-3-test3 the mountpoints 
stay in /mnt and are not moved to /media where they are if you do a 
clean install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. update fedora-core < version 2 to fedora-core-3-test3    

Actual Results:  mountpoints for removable media stay in /mnt

Expected Results:  mountpoints for removable media should be in /media

Additional info:
Comment 3 David Zeuthen 2004-10-20 12:43:21 EDT
We do run 'fstab-sync --clean' when the hal daemon starts, but we
earlier didn't want to touch entries outside of /media. However, this
works for me with hal-0.4.0-5 (testing by manually editing the /etc/fstab)

[root@davidz hald]# cat /etc/fstab|grep cdrom
/dev/cdrom              /mnt/cdrom              iso9660,udf
user,fscontext=system_u:object_r:removable_t,ro,exec,noauto,kudzu 0 0
[root@davidz hald]# service haldaemon restart
Stopping HAL daemon:                                       [  OK  ]
Starting HAL daemon:                                       [  OK  ]
[root@davidz hald]# cat /etc/fstab|grep hdc
/dev/hdc                /media/cdrecorder       iso9660,udf
pamconsole,fscontext=system_u:object_r:removable_t,ro,exec,noauto,managed
0 0
[root@davidz hald]# cat /etc/fstab|grep cdrom

According to CVS this change was introduced on Thu Oct 14 18:37:28
2004 UTC (5 days, 22 hours ago) so try updating to latest Rawhide?

Thanks,
David
Comment 7 Matthias Bachert 2004-10-30 04:27:59 EDT
works after update to rawhide.

Note You need to log in before you can comment on or make changes to this bug.