Bug 13633 - lp is not autoloaded
Summary: lp is not autoloaded
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: modutils   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-09 21:36 UTC by Hans de Goede
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-27 19:21:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2000-07-09 21:36:17 UTC
lp.o is not autoloaded when printing to a local printer, causing printing
to a local printer to fail.

Add the following line to /etc/modules.conf to fix:
alias char-major-6 lp

Comment 1 Bill Nottingham 2000-07-11 05:09:11 UTC
I can't reproduce this here.

cat /dev/lp0 successfully loads lp.o, with only:

alias parport_lowlevel parport_pc

in /etc/modules.conf.

modprobe -c | grep lp prints out:

alias char-major-6 lp

so it should be in the default config.


Comment 2 Hans de Goede 2000-07-19 07:08:24 UTC
Your right, cat works, but somehow lpr does not.

I just verified this and it seems strange I guess cat just opens the file while
lpd (from LPRng) probably first stats it. Hmm, but then in the end the kernel
ends up calling "/sbin/modprobe char-major-6" for both.

To reproduce:
-install clean beta3
-install local printer
-lpr <file>
-watch how it keeps trying and lp never gets loaded (lpq)
-now add the above alias to /etc/modules.conf
-/etc/rc.d/init.d/lpd stop (this nukes the active tasks, bug / feature?)
-/etc/rc.d/init.d/lpd start
-lpr <file> (again)
-works

This might be my machine I haven't tried reproducing it on other machines. But
this is a pretty clean beta3, and a very solid all A-brand machine.


Comment 3 Hans de Goede 2000-07-27 19:21:14 UTC
Ok, this works fine now for me on a fresh install of 6.9b5, closing



Note You need to log in before you can comment on or make changes to this bug.