Bug 136330 - Missing dependancy on freetype-devel >= 2.1.9
Summary: Missing dependancy on freetype-devel >= 2.1.9
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-19 11:26 UTC by Daniel Veillard
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-06 10:37:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Veillard 2004-10-19 11:26:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040805 Firefox/0.9.2

Description of problem:
build will fail on RHEL3 because it has freetype 2.1.4


Version-Release number of selected component (if applicable):
firefox-0.10.1-1.0PR1.13

How reproducible:
Always

Steps to Reproduce:
1. try to build on RHEL3
2. see build fail
3. 
    

Actual Results:  build fail with missing fields in freetype descriptors.

Expected Results:  dependancy failure at --rebuild time

Additional info:

upgrading to freetype-2.1.9 seems to fix the problem
not sure what level of freetype added the required fields.
do we really need freetype configured in those days ?

Comment 1 Warren Togami 2005-01-06 10:37:29 UTC
This is no longer an issue in our latest firefox SRPM.  Just flip the
boolean at the top of the .spec, and it should rebuild successfully on
RHEL3.



Note You need to log in before you can comment on or make changes to this bug.