Bug 136347 - Machine becomes unusable when you pull pcmcia wireless card out
Machine becomes unusable when you pull pcmcia wireless card out
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-10-19 09:11 EDT by Daniel Walsh
Modified: 2015-01-04 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 11:40:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2004-10-19 09:11:14 EDT
Description of problem:
When I pull the wireless card out of my laptop, any network command
ifconfig, service network shutdown, ifdown eth1 hangs.

cardmgr process goes to 97% and can't  be killed.

The following messages start happening continuously

Oct 19 08:49:52 dhcppc1 kernel: airo: cmd= 21
Oct 19 08:49:52 dhcppc1 kernel: airo: status= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp0= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp1= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp2= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: cmd= 21
Oct 19 08:49:52 dhcppc1 kernel: airo: status= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp0= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp1= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp2= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: cmd= 2
Oct 19 08:49:52 dhcppc1 kernel: airo: status= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp0= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp1= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp2= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: cmd= 21
Oct 19 08:49:52 dhcppc1 kernel: airo: status= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp0= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp1= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp2= ffff
Oct 19 08:49:52 dhcppc1 netplugd[2590]: eth1: state ACTIVE flags
0x00001043 UP,BROADCAST,RUNNING,MULTICAST -> 0x00001002
BROADCAST,MULTICAST
Oct 19 08:49:52 dhcppc1 netplugd[24516]: /etc/netplug.d/netplug eth1
probe -> pid 24516
Oct 19 08:49:52 dhcppc1 kernel: airo: cmd= 21
Oct 19 08:49:52 dhcppc1 kernel: airo: status= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp0= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp1= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp2= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: cmd= 21
Oct 19 08:49:52 dhcppc1 kernel: airo: status= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp0= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp1= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp2= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: cmd= 21
Oct 19 08:49:52 dhcppc1 kernel: airo: status= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp0= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp1= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp2= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: cmd= 21
Oct 19 08:49:52 dhcppc1 kernel: airo: status= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp0= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp1= ffff
Oct 19 08:49:52 dhcppc1 kernel: airo: Rsp2= ffff
Oct 19 08:49:53 dhcppc1 net.agent[24529]: remove event not handled
Oct 19 08:49:53 dhcppc1 net.agent[24531]: remove event not handled
Oct 19 08:49:53 dhcppc1 netplugd[2590]: eth1: can't get flags: No such
device
Oct 19 08:49:53 dhcppc1 netplugd[2590]: eth1: state PROBING pid 24516
exited status 65280
Oct 19 08:49:53 dhcppc1 kernel: airo: cmd= 21
Oct 19 08:49:53 dhcppc1 netplugd[2590]: Could not bring eth1 back up
Oct 19 08:49:53 dhcppc1 kernel: airo: status= ffff
Oct 19 08:49:53 dhcppc1 netplugd[2590]: eth1: can't get flags: No such
device
Oct 19 08:49:53 dhcppc1 kernel: airo: Rsp0= ffff
Oct 19 08:49:53 dhcppc1 kernel: airo: Rsp1= ffff
Oct 19 08:49:53 dhcppc1 kernel: airo: Rsp2= ffff
Oct 19 08:49:54 dhcppc1 kernel: airo: cmd= 21
Oct 19 08:49:54 dhcppc1 kernel: airo: status= ffff
Oct 19 08:49:54 dhcppc1 kernel: airo: Rsp0= ffff
Oct 19 08:49:54 dhcppc1 kernel: airo: Rsp1= ffff
Oct 19 08:49:54 dhcppc1 kernel: airo: Rsp2= ffff
Oct 19 08:49:54 dhcppc1 netplugd[2590]: eth1: can't get flags: No such
device
Oct 19 08:49:55 dhcppc1 kernel: airo: cmd= 21
Oct 19 08:49:55 dhcppc1 kernel: airo: status= ffff
Oct 19 08:49:55 dhcppc1 kernel: airo: Rsp0= ffff
Oct 19 08:49:55 dhcppc1 kernel: airo: Rsp1= ffff
Oct 19 08:49:55 dhcppc1 kernel: airo: Rsp2= ffff
Oct 19 08:49:55 dhcppc1 netplugd[2590]: eth1: can't get flags: No such
device
O


Can not reboot the machine.   Have to turn it off and back on to clear
up the problem.

Version-Release number of selected component (if applicable):

kernel-2.6.8-1.610
pcmcia-cs-3.2.7-1.14


How reproducible:

Everytime.

Steps to Reproduce:
1.  Bring laptop up on a wireless network
2.  Pull wireless card out.


Expected results:
Cardmgr should not have problems.  Machine should be able to start
network on ethernet cable.

Additional info:
Comment 1 Dan Williams 2004-10-23 12:37:34 EDT
When cardmgr goes to 97%, can you attach to it with gdb and post a
backtrace to this bug report?

If you still have this problem on Monday, let me drop by your cube and
try to diagnose.  My suspicion is (completely unfounded) that netplugd
doesn't know that the device is gone (becuase cardmgr is hung and
hasn't signaled the unplug event to hotplug scripts, or the driver
can't unload, etc) because either cardmgr is hung for some unrelated
reason, or becuase netplugd is still holding onto the driver, because
it doens't know the card is gone, because... (etc).  Don't drivers
have a usage count or something?  I've see messages such as "Usage
count is 5, cannot unload driver" on shutdown a number of times.
Comment 2 Pekka Pietikäinen 2004-10-24 08:00:21 EDT
Not networking ones, these days. This used to be the case, but there
were tons of races (resulting in shutdowns getting stuck etc.), and
apparently doing usage count tracking for networking is:

14:58 < arjan> too expensive to count
14:59 < arjan> instead afaik stuff deals with nic drivers just going way

Of course, from the impression I have from linux-kernel, pcmcia in
2.6.9 has "issues".
Comment 3 Daniel Walsh 2004-10-25 11:40:37 EDT
Ok, I reinstalled my machine with the latest from FC3.  And this
problem has dissappeared.  A few entries in the log file that the card
was removed and then it quiets down.  So I am going to close the bug.

Dan

Note You need to log in before you can comment on or make changes to this bug.