Bug 136355 - too many temp files
Summary: too many temp files
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Adrian Likins
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-19 14:08 UTC by Need Real Name
Modified: 2014-01-21 22:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-19 12:51:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2004-10-19 14:08:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040929

Description of problem:
Yum uses stores too many header files in /tmp
It makes trying to find a non-yum temp file more difficult than it
should be.

It would be nicer if yum created a directory under /tmp and stored the
headers there.

 $ ls -1 /tmp/*hdr|wc -l
969


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

Comment 1 Seth Vidal 2004-10-19 14:12:49 UTC
It makes the .hdr files in cachedir/repoid/headers/

I'm not sure where or why you're getting them in /tmp

Comment 2 Seth Vidal 2004-10-19 14:18:23 UTC
I've been told by people who know that you don't mean yum, you mean
up2date.
Reassigning.


Comment 3 Paul Nasrat 2004-10-19 14:45:01 UTC
Root cause - urlretrieve.

We probably want to honour --tmpdir rather than using urllib's temp
file  creation.  Maybe set tempfile.tempdir.

import urllib
(fn, h) =
urllib.urlretrieve("http://porkchop.redhat.com/nightly/rawhide-latest/i386/headers/4Suite-0-1.0-3.i386.hdr")
print fn
'/tmp/tmp5p7cw9.hdr'

Comment 4 Csongor Fagyal 2005-03-16 01:40:50 UTC
I have the same problem. Installed FC3 a few days ago, but already
hundreds of .hdr files in /tmp.

Comment 5 Need Real Name 2005-07-01 20:03:42 UTC
Obsolete?

Comment 6 Need Real Name 2005-10-14 12:17:33 UTC
Seems fixed to me.


Note You need to log in before you can comment on or make changes to this bug.