Bug 136383 - /tmp/myrequires should be handled otherwise
/tmp/myrequires should be handled otherwise
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-19 12:58 EDT by Jos Vos
Modified: 2010-01-11 22:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-22 15:38:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2004-10-19 12:58:28 EDT
Description of problem:

The spec file now creates a /tmp/myrequires in the core of the spec
file.  The right way (or at least a better way) to do this is to
include the file, say gfs-requires, as Source1 and %define
__find_requires %{SOURCE1} (it might be that the %define should be
after the Source1, I don't know for sure).

The problem with /tmp/my_requires is that builds might conflict w.r.t.
ownership etc.  The simple example I saw was a -bs done as root
followed by a --rebuild done as a normal user, which caused errors
because the file was owned by root.  If more packages would use a
similar method, this would even cause everything being screwed up.

Version-Release number of selected component (if applicable):
6.0.0-15
Comment 1 Jos Vos 2004-10-19 14:09:47 EDT
The "%define .." should indeed be moved after "Source1: ..." in that
case, I just checked.
Comment 2 Chris Feist 2004-11-04 15:13:43 EST
This bug will be fixed in the next build of GFS for RHEL-3.  It
appears the best solution is the put the my_requires file into the
%_buildir directory which allows us to keep everything in the .spec
file and not distribute extra files to build the rpm.
Comment 3 Lon Hohberger 2009-12-22 15:38:49 EST
Cleanup.

This bugzilla should be resolved with the current packages from RHN for Red Hat Global File System for Red Hat Enterprise Linux 3.

GFS-6.0.2.36-9

Note You need to log in before you can comment on or make changes to this bug.