Bug 136390 - fdisk makes sgi disklabels with huge volume headers
Summary: fdisk makes sgi disklabels with huge volume headers
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: util-linux (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Karel Zak
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-19 17:36 UTC by Eric Sandeen
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 15:44:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:058 normal SHIPPED_LIVE util-linux bug fix update 2005-05-18 04:00:00 UTC

Description Eric Sandeen 2004-10-19 17:36:42 UTC
Description of problem:

fdisk makes invalid sgi disklabels - volume header is too large

Version-Release number of selected component (if applicable):

util-linux-2.12a-6 (and all earlier)


fdisk automatically allocates the volume header partition as a
fraction of available disk space; for large storage this can
result in a huge waste of space.  Irix's "fx" tool defaults to
4k blocks, it makes sense for fdisk to do this as well.  The
size can always be increased manually.

This patch has already been sent to Andries (util-linux maintainer):

--- util-linux-2.11y/fdisk/fdisksgilabel.c.orig 2004-06-08
16:23:40.000000000 -0500
+++ util-linux-2.11y/fdisk/fdisksgilabel.c      2004-06-08
16:24:14.000000000 -0500
@@ -632,8 +632,8 @@
             * (like sash, symmon, fx, ide) with ca. 3200
             * sectors.
             */
-           if( heads * sectors * 5 < sgi_get_lastblock() )
-               sgi_set_partition( n, 0, heads * sectors * 5,
SGI_VOLHDR );
+           if( 4096 < sgi_get_lastblock() )
+               sgi_set_partition( n, 0, 4096, SGI_VOLHDR );
            break;
        }
     }

upstream parted also uses this same caculation.

(This is a bug in RHEL3 as well - if you can push the fix back there
too that'd be great.)

Thanks,

-Eric

Comment 1 Elliot Lee 2004-12-03 18:57:26 UTC
I'm wondering how to reconcile this change with the changes suggested
in #140437... Is there a conflict?

A RHEL3 erratum is extremely unlikely, but the fix definitely makes
sense for the devel tree.

Comment 2 Eric Sandeen 2004-12-03 20:21:52 UTC
It looks like fx will make the default volume header
4k sectors, regardless of sector size.  So I don't think there's
anything to reconcile...?

Just a note as well, this fix has been accepted upstream.

I understand that there's not really a pressing issue here for your
RHEL3 customers.

Thanks,

-Eric

Comment 5 Karel Zak 2005-05-12 15:44:52 UTC
It looks that the patch for this bug is missing in RHEL3 errata
(RHBA-2005:058-05) although the errata description text says something obverse.
It's mess...

It's fixed in devel/FC4 only. Well, definitely RHEL5 and status -> NEXTRELEASE.

Comment 6 Tim Powers 2005-05-18 15:06:18 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-058.html



Note You need to log in before you can comment on or make changes to this bug.