RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1363905 - man page for ipa-replica-manage has a typo in -c flag
Summary: man page for ipa-replica-manage has a typo in -c flag
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 22:06 UTC by Josip Vilicic
Modified: 2016-11-04 06:00 UTC (History)
5 users (show)

Fixed In Version: ipa-4.4.0-10.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 06:00:10 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 0 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Josip Vilicic 2016-08-03 22:06:59 UTC
Description of problem:
man page for ipa-replica-manage has a typo.  Notice the duplicate -c flags:

man ipa-replica-manage
----
OPTIONS
...
       -f, --force
              Ignore some types of errors, don't prompt when deleting a master

       -c, --no-lookup
              Do not perform DNS lookup checks.

       -c, --cleanup
              When deleting a master with the --force flag, remove leftover references to an already deleted master.

Version-Release number of selected component (if applicable):
ipa-server.x86_64  4.2.0-15.el7_2.6

How reproducible:
100%

Steps to Reproduce:
1. man ipa-replica-manage

Actual results:
two entries for the -c flag

Expected results:
--no-lookup and --cleanup to have different 1-character switches

Comment 2 Jan Pazdziora 2016-08-16 12:44:12 UTC
Flipping component to ipa.

Comment 3 Petr Spacek 2016-08-22 06:32:55 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6233

Comment 4 Martin Bašti 2016-08-22 17:16:34 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/1142c3a28079316e2946ef008ad52e7e4cf89863

Comment 7 Kaleem 2016-09-12 06:18:24 UTC
Verified.


IPA Server:
===========
[root@dhcp207-129 ~]# rpm -q ipa-server
ipa-server-4.4.0-10.el7.x86_64
[root@dhcp207-129 ~]# 


snip from ipa-replica-manage man page:
======================================
       -v, --verbose
              Provide additional information

       -f, --force
              Ignore some types of errors, don't prompt when deleting a master

       -c, --cleanup
              When deleting a master with the --force flag, remove leftover references to an already deleted master.

       --no-lookup
              Do not perform DNS lookup checks.

       --binddn=ADMIN_DN
              Bind DN to use with remote server (default is cn=Directory Manager) - Be careful to quote this value on the command line

Comment 9 errata-xmlrpc 2016-11-04 06:00:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.