Bug 1363915 - soas f25 liveuser no longer logs in in live
Summary: soas f25 liveuser no longer logs in in live
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: sugar
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simon Schampijer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F25FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-08-03 23:11 UTC by satellitgo
Modified: 2016-11-15 11:57 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-15 11:57:09 UTC


Attachments (Terms of Use)
f25 soas liveuser not logging in (469.97 KB, image/png)
2016-08-03 23:16 UTC, satellitgo
no flags Details
f24-flat-fedora-live-soas.ks with gdm* added (13.01 KB, text/plain)
2016-09-08 04:51 UTC, satellitgo
no flags Details

Description satellitgo 2016-08-03 23:11:43 UTC
Description of problem:
soas liveuser no longer logs in in live

Version-Release number of selected component (if applicable):
This occurs in both f25 branched and todays f25 livemedia-creator build

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 satellitgo 2016-08-03 23:16:43 UTC
Created attachment 1187286 [details]
f25 soas liveuser not logging in

Comment 2 satellitgo 2016-08-03 23:17:49 UTC
Comment on attachment 1187286 [details]
f25 soas liveuser not logging in

soas is supposed to do an autologin to liveuser. It no longer does this

Comment 3 Fedora Blocker Bugs Application 2016-08-03 23:20:27 UTC
Proposed as a Freeze Exception for 25-beta by Fedora user satellit using the blocker tracking app because:

 non-blocking spin

Comment 4 Adam Williamson 2016-08-09 21:24:28 UTC
Discussed at 2016-08-08 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-08-08/f25-blocker-review.2016-08-08-16.01.html . Accepted as an Alpha freeze exception as it's an obviously visible issue in the live image which cannot be addressed with an update; we expect any fix to be as targeted as possible.

Comment 5 satellitgo 2016-09-08 04:51:49 UTC
Created attachment 1198896 [details]
f24-flat-fedora-live-soas.ks with gdm* added

Comment 6 satellitgo 2016-09-08 04:52:59 UTC
(In reply to satellitgo from comment #5)
> Created attachment 1198896 [details]
> f24-flat-fedora-live-soas.ks with gdm* added

Boots and installs correctly in f24 QEMU/kdm

Comment 7 Fedora Blocker Bugs Application 2016-09-08 04:55:07 UTC
Proposed as a Freeze Exception for 25-beta by Fedora user satellit using the blocker tracking app because:

 non blocking DE
approved for alpha as FE

Comment 8 Peter Robinson 2016-10-19 10:51:29 UTC
Should be fixed in https://pagure.io/fedora-kickstarts/pull-request/82

Comment 9 Peter Robinson 2016-10-19 13:42:14 UTC
OK PR is merged so should be fixed in tomorrow's (Thurs 20th Oct) Fedora 25 images. Can you test please?

Comment 10 satellitgo 2016-10-21 04:51:00 UTC
Fedora-SoaS-Live-x86_64-25-20161020.n.1.iso
still does not login (in virtual machine manager)

I also used 
https://pagure.io/fork/pbrobinson/fedora-kickstarts/raw/f25-soas/f/fedora-live-soas.ks with livemedia-creator in f25 workstation and it fails the same way

Comment 11 satellitgo 2016-10-21 16:05:34 UTC
Fedora-SoaS-Live-x86_64-25-20161021.n.0
-stops at liveuser login which does not start
(looks like x crash) returns to login screen
-selinux=0 on boot produces same result

Comment 12 Fedora Blocker Bugs Application 2016-10-24 16:36:22 UTC
Proposed as a Freeze Exception for 25-final by Fedora user satellit using the blocker tracking app because:

 non blocking DE

Comment 13 Geoffrey Marr 2016-10-24 18:28:32 UTC
Discussed during the 2016-10-24 blocker review meeting: [1]

The decision to retain classification as an AcceptedBlocker was made as this is a major issue regarding SoaS.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-10-24/f25-blocker-review.2016-10-24-16.01.txt

Comment 14 Adam Williamson 2016-10-24 19:05:08 UTC
FE, not blocker.

Comment 15 satellitgo 2016-10-26 21:49:40 UTC
Fedora-Everything-netinst-x86_64-25-20161023.n.0.iso
(x) sugar-desktop fails to login to installed user graphically

Fedora-SoaS-Live-x86_64-25-20161026.n.0.iso also fails

Comment 16 satellitgo 2016-11-13 20:23:19 UTC
Fedora-Everything-netinst-x86_64-25-1.2.iso USB install minimal with 19 DE's
to 512 GB ssD 
sugar 0.108.1 boots

Comment 17 Peter Robinson 2016-11-14 16:42:49 UTC
So the final issue was actually that it was auto loggingin but sugar was crashing due to a missing dep. The install of gdm or other things likely satisfied that dep. For reference next time check ~/.sugar/logs/shell.log as the very existence shows that it's attempting to run

Comment 18 satellitgo 2016-11-14 18:00:00 UTC
https://pagure.io/fedora-kickstarts/pull-request/99#request_diff

editing kickstart files with these changes produces a bootable working .iso
tested with f25 livemedia-creator flattened .ks

Comment 19 satellitgo 2016-11-15 01:17:23 UTC
https://wiki.sugarlabs.org/go/File:Shell.log.JPG
shell.log before fix

Comment 20 Peter Robinson 2016-11-15 11:57:09 UTC
Works in today's nightly compose


Note You need to log in before you can comment on or make changes to this bug.