Bug 1363991 - [userinterface_public_627]Event message flickered on Monitoring page
Summary: [userinterface_public_627]Event message flickered on Monitoring page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 08:35 UTC by Yadan Pei
Modified: 2017-03-08 18:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-19 12:55:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
EventsFlickering (45.43 KB, image/png)
2016-08-04 08:36 UTC, Yadan Pei
no flags Details
CleanEventMessageOnBrowseEventsPage (25.85 KB, image/png)
2016-08-04 08:36 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Yadan Pei 2016-08-04 08:35:56 UTC
Description of problem:
Event message flickered on Monitoring page when message is updated in high frequency

Version-Release number of selected component (if applicable):
v3.3.0.14

How reproducible:
Always

Steps to Reproduce:
1. Create a test dc, pod will not be running since we don't have sufficient permission to create privileged containers
$ cat dc.yaml
apiVersion: v1
kind: DeploymentConfig
metadata:
  labels:
    run: php-apache
  name: php-apache
spec:
  replicas: 1
  selector:
    run: php-apache
  template:
    metadata:
      labels:
        run: php-apache
    spec:
      containers:
      - image: gcr.io/google_containers/hpa-example
        imagePullPolicy: IfNotPresent
        name: php-apache
        resources:
          requests:
            cpu: 200m
        securityContext:
          privileged: true
      restartPolicy: Always
      securityContext: {}
      terminationGracePeriodSeconds: 30
  triggers:
  - type: ConfigChange

$ oc create -f dc.yaml
deploymentconfig "php-apache" created
2. When deployment is running, go to Monitoring page

Actual results:
2. During deployment process, it will try thousands of times to create pod, thus a lots of events is listed on Monitoring page and these events get flickered


Expected results:
2. It's better to show one message only with trying times increased 

Additional info:

Comment 1 Yadan Pei 2016-08-04 08:36:26 UTC
Created attachment 1187395 [details]
EventsFlickering

Comment 2 Yadan Pei 2016-08-04 08:36:56 UTC
Created attachment 1187397 [details]
CleanEventMessageOnBrowseEventsPage

Comment 3 Samuel Padgett 2016-08-04 14:16:05 UTC
This should be fixed by

https://github.com/openshift/origin-web-console/pull/276

which hasn't been vendored to origin yet.

Comment 4 Jessica Forrester 2016-08-04 19:22:27 UTC
Fix merging to origin in https://github.com/openshift/origin/pull/10222

Wait to put it in MODIFIED till its merged

Comment 5 Troy Dawson 2016-08-08 21:35:21 UTC
This has been merged and is in OSE v3.3.0.17 or newer.

Comment 7 Yadan Pei 2016-08-09 03:30:06 UTC
Checked against OCP v3.3.0.17

This fix wasn't merged yet

Comment 8 Yadan Pei 2016-08-09 03:33:20 UTC
I will check when puddle newer than v3.3.0.17 is ready

Comment 9 Troy Dawson 2016-08-09 13:27:11 UTC
If this is just waiting for a merge, it should be on Modified.  Setting it there.

Comment 10 Jessica Forrester 2016-08-09 15:43:31 UTC
This is another issue caused by the origin-web-console enterprise branch not getting updated correctly during the update for ose/master

Comment 11 Yadan Pei 2016-08-11 02:05:26 UTC
Hi, checked against v3.3.0.18, event message is displayed well now

Could change it to ON_QA and I could verify


Note You need to log in before you can comment on or make changes to this bug.