Bug 1364031 - Test failing on NetBSD. Need Access to the machine for debugging.
Summary: Test failing on NetBSD. Need Access to the machine for debugging.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nigel Babu
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 10:32 UTC by rjoseph
Modified: 2016-08-23 06:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 06:12:28 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
public key (744 bytes, text/plain)
2016-08-04 10:32 UTC, rjoseph
no flags Details

Description rjoseph 2016-08-04 10:32:07 UTC
Created attachment 1187422 [details]
public key

Description of problem:

https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/18505/consoleFull

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Niels de Vos 2016-08-04 11:11:19 UTC
test cases are not supposed to write to directories managed by the OS. They should confine their work under /build/... (or whatever the prefix is).

The fatal error seems to be this one:
   mkdir: /etc/ssl: Operation not permitted

Comment 2 rjoseph 2016-08-05 06:20:24 UTC
Do the current SSL test cases run on NetBSD?

e.g. tests/bugs/transport/bug-873367.t

Comment 3 Nigel Babu 2016-08-05 11:11:40 UTC
No need for a machine anymore to debug.

Comment 4 rjoseph 2016-08-16 06:48:29 UTC
The test is still failing after modifying the SSL path for NetBSD. Will need the machine for further analysis.

Comment 5 Nigel Babu 2016-08-16 06:57:05 UTC
You should be able to do the following:

ssh jenkins@nbslave75.cloud.gluster.org

You have this machine until Aug 23, 2016.

Please let me know once you're done with the machine or if you want an extension. After you're done, please delete any temporary files you may have created with your tests.

Comment 6 Nigel Babu 2016-08-23 06:12:28 UTC
rjoseph has confirmed this machine is no longer required. Putting this back in the pool.


Note You need to log in before you can comment on or make changes to this bug.