Bug 1364075 - SELinux is preventing qemu-system-x86 from read, write access on the chr_file renderD128.
Summary: SELinux is preventing qemu-system-x86 from read, write access on the chr_file...
Keywords:
Status: CLOSED DUPLICATE of bug 1337333
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4d3881274010d12dcd37510cc98...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 12:40 UTC by Joachim Frieben
Modified: 2016-08-11 10:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 10:16:09 UTC
Type: ---


Attachments (Terms of Use)

Description Joachim Frieben 2016-08-04 12:40:42 UTC
Description of problem:
SELinux is preventing qemu-system-x86 from read, write access on the chr_file renderD128.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that qemu-system-x86 should be allowed read write access on the renderD128 chr_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'qemu-system-x86' --raw | audit2allow -M my-qemusystemx86
# semodule -X 300 -i my-qemusystemx86.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:svirt_t:s0:c857,c999
Target Context                system_u:object_r:dri_device_t:s0
Target Objects                renderD128 [ chr_file ]
Source                        qemu-system-x86
Source Path                   qemu-system-x86
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-206.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.8.0-0.rc0.git3.1.fc25.x86_64 #1
                              SMP Fri Jul 29 15:09:59 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-08-04 13:23:52 CEST
Last Seen                     2016-08-04 13:23:52 CEST
Local ID                      74f20db6-1fff-4151-94ee-a76b82730d20

Raw Audit Messages
type=AVC msg=audit(1470309832.255:417): avc:  denied  { read write } for  pid=17496 comm="qemu-system-x86" name="renderD128" dev="devtmpfs" ino=11631 scontext=unconfined_u:unconfined_r:svirt_t:s0:c857,c999 tcontext=system_u:object_r:dri_device_t:s0 tclass=chr_file permissive=0


Hash: qemu-system-x86,svirt_t,dri_device_t,chr_file,read,write

Version-Release number of selected component:
selinux-policy-3.13.1-206.fc25.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.0-0.rc0.git3.1.fc25.x86_64
type:           libreport

Potential duplicate: bug 1337333

Comment 1 Joachim Frieben 2016-08-07 11:24:47 UTC
No improvement by recommended local policy module generated by:

ausearch -c 'qemu-system-x86' --raw | audit2allow -M my-qemusystemx86
semodule -X 300 -i my-qemusystemx86.pp

Comment 2 Lukas Vrabec 2016-08-11 10:16:09 UTC

*** This bug has been marked as a duplicate of bug 1337333 ***


Note You need to log in before you can comment on or make changes to this bug.