Bug 1364201 - evince does not show letters in selected section of pdf text
Summary: evince does not show letters in selected section of pdf text
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: evince
Version: 24
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 17:21 UTC by ingli
Modified: 2016-08-05 12:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-05 12:40:28 UTC
Type: Bug


Attachments (Terms of Use)
pdf for testing (147.56 KB, application/pdf)
2016-08-04 17:21 UTC, ingli
no flags Details
screenshot of effect (65.27 KB, image/png)
2016-08-04 17:22 UTC, ingli
no flags Details

Description ingli 2016-08-04 17:21:22 UTC
Created attachment 1187591 [details]
pdf for testing

Description of problem:

I have a pdf of a scanned/OCRed text (produced via pdfsandwich through tesseract). When I open the pdf with evince and select a text section, I cannot see the letters. When I do the same with okular, I can still see the letters.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. open the attached odf file with evince
2. select text

Actual results: cannot see the letters that are selected


Expected results: can see the letters


Additional info:
I do not think this is an issue of pdfsandwich - but here is a link to this mechanism. http://www.tobias-elze.de/pdfsandwich/

Comment 1 ingli 2016-08-04 17:22:59 UTC
Created attachment 1187592 [details]
screenshot of effect

sorry, the other file is the pdf

Comment 2 Marek Kašík 2016-08-05 12:40:28 UTC
Hi,

this is an issue in the PDF file. It contains a font which doesn't have any usable glyphs (they named it GlyphLessFont). It has only .notdef and .null replacements (the squares). Evince uses the .notdef glyph if there is no glyph for the character. The reason that Okular highlight the text is because it does it in the image not as a regular text as evince does.

Regards

Marek


Note You need to log in before you can comment on or make changes to this bug.