Bug 1364220 - Skipping "horizon" postconfig with latest openstack-tripleo-heat-templates
Summary: Skipping "horizon" postconfig with latest openstack-tripleo-heat-templates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Jiri Stransky
QA Contact: Ido Ovadia
URL:
Whiteboard:
: 1353696 1379893 (view as bug list)
Depends On: 1347063
Blocks: 1305654 1353696
TreeView+ depends on / blocked
 
Reported: 2016-08-04 18:15 UTC by Mike Orazi
Modified: 2018-02-11 15:33 UTC (History)
34 users (show)

Fixed In Version: python-tripleoclient-5.0.0-0.20160907170033.b0d7ce7.el7ost
Doc Type: Bug Fix
Doc Text:
OpenStack Dashboard (horizon) was incorrectly included in list of services the director uses to create endpoints in OpenStack Identity (keystone). A misleading 'Skipping "horizon" postconfig' message appeared when deploying the overcloud. This fix removes horizon from the service list endpoints added to keystone and modifies the "skipping postconfig" messages to only appear in debug mode. The misleading 'Skipping "horizon" postconfig' message no longer appears.
Clone Of: 1347063
Environment:
Last Closed: 2016-12-14 15:48:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 357039 None None None 2016-08-18 09:21:02 UTC
Launchpad 1614115 None None None 2016-08-18 09:19:56 UTC
Red Hat Knowledge Base (Article) 2380351 None None None 2016-08-04 18:15:30 UTC
Red Hat Knowledge Base (Solution) 2446961 None None None 2016-12-03 06:26:46 UTC

Comment 1 Jiri Stransky 2016-08-16 14:24:15 UTC
Vincent i see you reported the original bug 1347063. Can you please help me understand the impact of this bug -- does it break anything in terms of functionality or is it just a confusing message being printed? On bug 1347063 you mentioned that horizon actually works.

I'm wondering if the right thing to do here is to just stop attempting to create an endpoint for Horizon. I vaguely recall that this endpoint was needed only by the original Tuskar UI but i'm not sure if it's still needed for anything nowadays. Scanning the internets, i couldn't find any mentions of people creating a keystone endpoint for Horizon and using it for anything.

Comment 2 Jiri Stransky 2016-08-16 14:26:49 UTC
Jirka, do you know if TripleO UI needs the overcloud Horizon endpoint for something?

Comment 3 Jiri Tomasek 2016-08-16 14:41:17 UTC
TripleO UI does not currently need overcloud Horizon endpoint. I think it is ok to remove it, especially if such implementation is incomplete and causes bugs.

Comment 4 Vincent S. Cojot 2016-08-16 16:07:56 UTC
Hi Jiri,
Horizon works but the 'horizon' service does not get populated anymore in 'keystone service-list'. I have no idea what uses that part, btw.

Comment 5 Andreas Karis 2016-08-16 16:14:38 UTC
Hello,

If horizon worked, we wouldn't have opened the bug. This is not about the endpoint. Horizon is not accessible without the above workaround.

Comment 6 Andreas Karis 2016-08-16 16:19:54 UTC
(at least my customers couldn't access horizon)

Comment 11 Jiri Stransky 2016-08-18 09:19:56 UTC
Thanks for the info all. Seems like this is not a functional problem but has a potential to generate confusion.

Comment 13 Jiri Stransky 2016-09-19 15:08:50 UTC
Merged, it's on the way to Newton.

Comment 17 Mike Burns 2016-09-29 05:58:52 UTC
*** Bug 1379893 has been marked as a duplicate of this bug. ***

Comment 18 Ido Ovadia 2016-10-06 16:07:40 UTC
Verified
========
python-tripleoclient-5.2.0-1.el7ost.noarch

Comment 22 Radomir Dopieralski 2016-10-20 11:40:13 UTC
*** Bug 1353696 has been marked as a duplicate of this bug. ***

Comment 24 errata-xmlrpc 2016-12-14 15:48:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.