Bug 136428 - Pango 1.6.0-4 returns unvarying line heights in SWT and Eclipse
Pango 1.6.0-4 returns unvarying line heights in SWT and Eclipse
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-19 19:29 EDT by Steven Lawrance
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 20:11:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Lawrance 2004-10-19 19:29:05 EDT
Description of problem:
SWT in Eclipse uses Pango to calculate line heights for its text
editor, or at least that is what I could tell from
http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.swt.graphics.text/Eclipse%20SWT/gtk/org/eclipse/swt/graphics/text/TextLayout.java?rev=1.25&content-type=text/vnd.viewcvs-markup
After upgrading to Pango 1.6.0-4, the line heights in Eclipse became
fixed to 10pt regardless of the font size.

Version-Release number of selected component (if applicable):
Pango 1.6.0-4
Eclipse 3.1M2

How reproducible:
Always.

Steps to Reproduce:
1. Use Eclipse with Pango 1.6.0-3 or below. Change the line height in
the text editor to different sizes such as 9pt, 20pt, 48pt, 8pt, and
so forth. Exit Eclipse.
2. Upgrade to Pango 1.6.0-4
3. Run Eclipse. Try the steps in Step 1 again and notice that the line
height never changes even though the font size changes.
  
Actual results:
If the font is set to a high point size, the fixed line height of
approximately 10pt makes the text almost invisible as you only see the
top parts of the characters. If the font is set below 10pt, you see
the font, but the lines are too high. If you set the font to 10pt, it
looks perfect.

Expected results:
Line height should adjust depending on the font's point size.

Additional info:
I think it may have been caused by the "Move place where we compute
fontset metrics to fix problems with line height in CJK locales
(#131218)" change.
Comment 1 Owen Taylor 2004-10-19 20:05:12 EDT
Thanks a lot for catching this ... pango-1.6.0-5 (currently building,
should be in Raw Hide within the next day) has a fix:

* Tue Oct 19 2004 Owen Taylor <otaylor@redhat.com> - 1.6.0-5
- Fix problem in the last patch where we weren't getting the metrics
from the
  right font description (#136428, Steven Lawrance)
Comment 2 Steven Lawrance 2004-10-20 13:48:58 EDT
Confirmed that Eclipse's text editor has proper line heights in
1.6.0-6. Thanks for the quick solution :-).

Note You need to log in before you can comment on or make changes to this bug.