Bug 136429 - Reply-To: header field messes up reply-to-all command
Reply-To: header field messes up reply-to-all command
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mailx (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-19 19:29 EDT by Paul Vojta
Modified: 2008-05-09 13:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 05:52:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Vojta 2004-10-19 19:29:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; rv:1.7.3) Gecko/20040916
Firefox/0.10.1

Description of problem:
If a message has the Reply-To: header field set, and I reply to it
using the R command (with Replyall set) or the r command (without
Replyall set), then my reply is addressed only to the address in the
Reply-To header field, and not other recipients or addresses listed
in the Cc: field.

This is contrary to what mailx does under Solaris 8, and what mutt does
(and probably other mail programs).

Version-Release number of selected component (if applicable):
mailx-8.1.1-32

How reproducible:
Always

Steps to Reproduce:
1.  Create a file "foo" with a message in it, including Reply-To:
header field, multiple addresses listed under To:, and a Cc: header line.
2.  type mail -f foo
3.  type set Replyall
4.  type R
5.  Notice that the message is only going to one person, not the Cc:
recipients or the others listed under To:
    

Actual Results:  The recipients other than you, and the Cc: list are
not included among
the recipients of the reply message

Expected Results:  The other "To:" recipients in the original message
should be listed under "To:" for the reply message, and the Cc: list
should be carried over.

Additional info:
Comment 1 Jiri Ryska 2004-10-27 09:39:25 EDT
It is hard to say if this is a bug because RFC 822
http://www.w3.org/Protocols/rfc822/ says:
> If the "Reply-To" field exists, then the reply  should
> go to the addresses indicated in that field and not to
> the address(es) indicated in the "From" field.

But if mailx under Solaris 8 does then there should be different
version of mailx and this feature was added/removed from mailx.
Comment 2 Paul Vojta 2004-10-27 12:56:51 EDT
In other words (in my interpretation) the RFC says that the "Reply-To"
field causes the address(es) in the "From" field of the original message
to be replaced by the addresses in the "Reply-To" field, and if the MUA
was going to send the reply to other addresses (e.g., in the "To" field
or the "Cc" field), then it should still send it to those addresses.

Yes, mailx in Solaris is very different.  It has lots of new features.
Comment 3 Ivana Varekova 2004-11-16 09:11:38 EST
Commands r and R was changed 
if you fill Reply-To header 
r - adresse the message to adresses in the header fields From:, To:
and Reply-To:, the Cc: header field is copied.
R - adresse the message to adresses in the Reply-To header field.
IV
Comment 4 Ivana Varekova 2004-12-03 05:52:03 EST
Solved with -40.

Note You need to log in before you can comment on or make changes to this bug.